Raspian sees phat DAC, but no audio out


#1

hey there, title says it all. did lots of research before testing, but stuck: device seems set up correctly, but no audio out. have tried several different line-level amps, headphones, etc

speaker-test 1.1.3

Playback device is default
Stream parameters are 48000Hz, S16_LE, 2 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 96 to 1048576
Period size range from 32 to 349526
Using max buffer size 1048576
Periods = 4
was set period_size = 262144
was set buffer_size = 1048576
 0 - Front Left
 1 - Front Right
Time per period = 3.146485
 0 - Front Left
 1 - Front Right
Time per period = 3.157521
 0 - Front Left
 1 - Front Right
Time per period = 3.156208
 0 - Front Left
 1 - Front Right

what other info can i provide to help troubleshoot?

edited to include:

aplay -L
default
    Playback/recording through the PulseAudio sound server
null
    Discard all samples (playback) or generate zero samples (capture)
sysdefault:CARD=sndrpihifiberry
    snd_rpi_hifiberry_dac,
    Default Audio Device
dmix:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Direct sample mixing device
dsnoop:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Direct sample snooping device
hw:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Direct hardware device without any conversions
plughw:CARD=sndrpihifiberry,DEV=0
    snd_rpi_hifiberry_dac,
    Hardware device with all software conversions

#2

Could you provide the following:

  1. What type of Raspberry Pi is it?
  2. If it’s a Pi Zero - what type of header?
  3. What type of header on the pHAT DAC?
  4. Could you post pictures of soldering/wiring?

Technically the Pi doesn’t and cannot “see” the DAC, if the software is set up correctly it’ll try to output data to it, but it has absolutely no idea if the board is actually present- so sometimes the DAC showing up can be misleading.


#3

pi zero w, standard 40pin female header on the phat and male on the pi, will post photos when i am back at the pi.


#4

is the output of aplay -L solely based upon config from your install script? no hardware detection in that mix at all?


#5

Yes, it’s purely from the install script. If you were to remove the pHAT you’d see exactly the same thing. The installer sets up the Pi to output the right signals on the right pins to drive a DAC, but the Pi doesn’t care if the DAC is actually there or not.


#6

ah, thanks, good to know. my header soldering is a nightmare, i am not very experienced. could it be that’s the issue? can you tell me which pins are critical connections?


#7

The key pins for pHAT DAC are documented here:

If you share some pictures, I’d be happy to give you some pointers about tidying up the soldering. We all have to start somewhere!

Update: oh and yes, speaking from experience a flaky connection is much more likely to be the problem than a faulty pHAT.


#8

so, i initially soldered the header upside down. removing it was tough for my skill level, i am pretty sure i also removed a few of the pads around some pin holes. is that the end of the board?


#9

It looks like pin 18 (sixth from the bottom right corner in your photo) isn’t soldered adequately, if at all, and that’s one of the I2S pins required by pHAT DAC. Try adding a bit more solder, although if you’ve ripped the pad off then that won’t necessarily help. :-(

If you’re having trouble soldering, then we’ve got a new solderless kit called Pogo-a-go-go for attaching pHATs to Pi Zeros, or there’s always our hammer headers.


#10

i tested that and no go, i think a pad or two were removed when i tried to remove the header. will chalk this one up to learning.