Help in diagnosing pHAT DAC no-sound issue. Faulty HW?

Trying to get Mopidy with Spotify to work on my RPi Zero W and pHAT DAC. I’ve followed the Pimoroni guides for both, using the single line simple setup procedure. I just can’t seem to get any audio out from my DAC. I’ve gotten Mopidy and Spotify to work OK with the Iris front end getting authenticated with Spotify and seemingly able to play tracks from Spotify. Without any sound. I did notice that the output section of the Iris UI says “no outputs”

I’ve tried on a fresh Raspbian Buster install and then dug out a fresh Jessie and no sound. With Buster dmesg did show up some bcm-related errors but nothing of the sort with Jessie.

Is there some way to ascertain that the pHAT DAC is fully working? I’ve seen similar topics on these forums, most seemed inconclusive except one where the user had a possibly faulty pHAT DAC since replacing the unit seemed to fix his or her issue.

What do you have plugged into the line out?
Earbuds will work but if your using speakers they will need to be amplified speakers.
Raspbian full or Lite?
Raspbian Buster?

Active speakers. When I was trying Buster it was the lite version, but with Jessie it was the full install.

Ok, with the full Jessie right click the speaker icon in the tray and see what is set as default audio device.
From command line I guess you’ll have to run alsa config. I used to know how to do that, I’d have to Google now though.

This is rather embarrassing… Due to how my project was initially supposed to be built, I have a male pin header on the DAC and a female header on the RPi. I guess some pins were too short and did not make contact since the DAC works fine with the necessary pins connected with duponts.

So my problem was solved. Thanks for your help!

Stuff like that happens from time to time. At least you figured it out and weren’t left scratching your head wondering what’s wrong.

What headers did you use?