pHAT DAC no sound through 3.5mm Audio


#1

Hi;

I have just soldered up and fitted a pHAT DAC to a Raspberry Pi 3.

I ran the automated setup script and the sound test worked fine however if I try and play music using either omxplayer in the terminal or using Kodi I get no sound from the DAC?

I checked out this post and all the checks show hifiberry dac wher it is supposed to?

If I run the speaker test on its own it works fine.
I have also noticed that the speaker icon in the title bar on the desktop is now muted and cannot be unmuted?
If I select audio preferences I get a message saying that No ALSA audio devices were detected and that I should enable the internal audio or connect a USB or HAT audio device.
Any ideas?


#2

The application you use for playback should support ALSA. omxplayer does not support ALSA I’m afraid. Kodi I believe should work, or at least I have read that some players included do. See here:

https://www.raspberrypi.org/forums/viewtopic.php?t=106122&p=742940


#3

I was just typing as you replied.

I found this thread.
Which explains the issue with omxplayer!!

Anyway in Kodi I just realised you can change the audio output and select hifiberry dac…Iron Man 3 AC/DC Shoot to Thrill is now pumping out of my speakers!!!

What a fantastic product the pHAT DAC is - well done PiMoroni!!!

Now how do I control the volume without fitting an inline volume control (mind you when its in the car (where it is destined) i’ll control the audio through the amp!!!


#4

analogue control - i.e what you’ll be doing in your car is probably your best bet, and should preserve audio quality. That said controlling volume in software is an option, depends on the application.