pHAT DAC Install works with vlc but audio device setting problem


#1

Setup:
Pi3A+ Raspbian Linux 4.14.98-v7+ #1200 SMP Tue Feb 12 20:27:48 updated
pHAT DAC connected using GPIO female connector soldered

Installation:
curl script in Pimoroni did not work due to proxy, thus manual set up followed
Step 1 Black list file empty, Step 2 snd_bcm2835 absent in /etc/modules
Step 3 did create asound.conf as instructed
Step 4 added dtoverlay for hifiberry, commented out dtparam=audio=on and additionally removed comment on dtparam=i2s=on.

What works:
Playing mp3 using vlc player works beautifully, volume control works on vlc player.
aplay -l command shows
**** List of PLAYBACK Hardware Devices ****
card 0: sndrpihifiberry [snd_rpi_hifiberry_dac], device 0: HifiBerry DAC HiFi pcm5102a-hifi-0
Subdevices: 1/1
Subdevice #0: subdevice #0

What does not work:

clicking on audio device setting panel gives this message " No ALSA audio device were detected. enable the internal audio device, or connect a USB or HAT audo device"
Desktop sound control panel does not work.

Audacious complains " ALSA error: No suitable mixer element fount " but plays the file without any control over volume

Any suggestion or explanation would be appreciated.

Observation: Headphone works as well. Used Sennheiser PX80. Tested with headphone as well as auxiliary input of JBL FLIP4. Both sound flawlessly.


#2

hello,it seems its working as its suppose to work ,I followed instruction here Display-o-Tron: toy music player with scrolling colors Mine works same way and I knew it would after i read those instructions …If you need to use the default sound device i would suggest maybe install raspbian on another microSD card ,and swap back and forth ,or use another Pi Zero .
I built mine knowing i wanted a Pi zero mp3 player, i didnt know at first it was going to work the way it does after doing the install of the phat


#3

In order for volume control to work on pHAT DAC - since the hardware doesn’t support it - you need to set up the softvol plugin in asound.conf. See: Speaker Phat + Retropie Voume

I think the audio device setting panel for the Pi is somewhat quirky and tends to drop an ~/.asoundrc file to set the audio device, which overrides any custom settings in asound.conf. It’s been a while since I’ve looked into it, but this tends to break things so we favour disabling it, disabling built-in audio and just letting the DAC be the only option for output.


#4

Thank you both for prompt reply. I will follow the suggestion and will come back to write what happened finally. Two more related question. Q1. Will installing any mixer help ? Q2. Do you have a particular low overhead music organizer player software in mind which works with this board (other than vlc)?


#5

Update: This is what I have learned about the issue in the past few days.

OMXplayer does not use alsa so even after correct setting, it will not work with pHAT DAC. Whatever player we use, it have to have option to use ALSA to output sound. Settings in Pimoroni Instruction and ALSA site about adding softvol option in /etc/asound.conf and .asoundrc are quite the same. After that one have to use alsamixer in the command line and have to ensure (F6) that pHAT DAC is set as default card. Once done, audio device setting using PCM and volume control works. I set it to 75% which gives me correct output level for my headphone as well as Flip4. Use of this softvol can potentially reduce the quality, but in practice, it still sounding great. I am using vlc at the moment with ALSA set as out put device. More update and details if I learn more.