pHAT Stack - My pile!


#1

After reading @sandyjmacdonald 's Learn article https://learn.pimoroni.com/tutorial/sandyj/build-an-itty-bitty-beat-box I was ,like, I need this! I already had a Drum HAT + Piano HAT so I got me a pHAT Stack and built one, just replacing the Speaker pHAT with a pHAT DAC. Connected the output to a decent stereo amp with big loudspeakers, so the neighbours could enjoy it too… Perfect! Great sound!

Soon I started hoping there was a display, so I wouldn’t have to connect the Pi with a monitor. I have this Adafruit PiTFT+ 3.5, which I had not used for a while. I wasn’t very confident will this setup work or not. Found this post: Possible Change Phat Dac GPIO pins to allow Adafruit PITFT 3.5?
so I went ahead and just installed all the needed Pimoroni software on a fresh Adafruit PiTFT image: https://learn.adafruit.com/adafruit-pitft-3-dot-5-touch-screen-for-raspberry-pi/easy-install
It’s a bit shame Adafruit hasn’t updated the image; the RPi0W’s inbuilt WiFi + bluetooth won’t work with this image. So, I connected a USB hub (with Ethernet!) and plugged in a mouse/keyboard receiver, a USB WiFi plug, and a thumbdrive. Now there’s a WiFi connection!

In addition to Piano HAT scripts (fully functional!), I needed a music player software. This time I went with Audacious, for it’s classic Winamp skin, which is just perfect for the display.

Everything runs as expected, no errors, no overheating components, no sparkles/smoke.

I’ve built a pile of Pi based music players, but this is definitely the coolest one!


#2

Nice, really nice. I so want to get a pHat Stack. I will eventually. Already have the original Black hat Hack3r and Mini Hack3r. two Mini hack3rs actually.
Adafruit have some really cool stuff, I’ve bought a lot of stuff from them. The Raspberry Pi seems to be an after thought though? A lot of their sensor breakout boards etc are all set for Arduino, but no Python libraries for Raspbian?
On the Raspberry Pi forums I’ve read where support for the PiTFT GPIO displays is now backed into Raspbian. You may not have to use a custom image, all you may have to do is a config.txt edit? I don’t have a PiTFT to confirm that myself though. If you have a spare SD card might be worth a try.


#3

@alphanumeric, I was just too lazy to do the manual install for the PiTFT…


#4

No problem, enjoy. A friend of mine did a similar setup, Piano Hat, and Drum Hat, and I think Speaker pHat? And just used an image already done up.


#5

FYI, don’t waste your time attempting manual install for PiTFT+ 3.5 on a fresh Stretch. It is NOT possible due to several reasons. If someone, somehow, manages to do it, please share! I’m all ears (or eyes) here.


#6

Reading through this thread could be useful: https://forums.adafruit.com/viewtopic.php?f=47&t=122926
I did read it, but still no success.


#7

Since their instructions start with “replace the entire foundation kernel with our own” I’d imagine it breaks a lot of things.

I had similar problems with trying to support the RoboPeak USB Display, which had been left out in the cold by the manufacturer.

I wonder if the kernel replacement step is even needed anymore since the dtoverlay, at least, is upstreamed in the foundation’s firmware: https://github.com/raspberrypi/firmware/blob/master/boot/overlays/pitft35-resistive.dtbo

Maybe you could- on a fresh Stretch image- try skipping directly to adding this to the end of /boot/config.txt:

dtparam=spi=on
dtparam=i2c1=on
dtparam=i2c_arm=on
dtoverlay=pitft35-resistive,rotate=90,speed=42000000,fps=20

And see if anything happens.


#8

@gadgetoid, I started with a fresh 2017-11-29-raspbian-stretch.img

Inserted the SD card in RPi0W with HDMI monitor, keyboard/mouse, eth0 connected.

Did some localization configurations.

nano’d /boot/config.txt and added your suggested configuration.

Rebooted. At some point, PiTFT turns from white to black, but still no desktop on PiTFT…

HDMI output is good.


#9

Started over again, with 2017-09-07-rasbian-strecth.img,
replicating the steps described here:
https://forums.adafruit.com/viewtopic.php?f=47&t=122926&start=30#p630909

“we log into it over ssh and run apt-get update & apt-get upgrade, then reboot”
(It’s unclear what got upgraded at the time of this written (November 2017))

Adafruit-PiTFT-Helper2 shell script adds to /boot/config.txt :

[pi0]
device_tree=bcm2708-rpi-0-w.dtb
[pi1]
device_tree=bcm2708-rpi-b-plus.dtb
[pi2]
device_tree=bcm2708-rpi-2-b.dtb
[pi3]
device_tree=bcm2708-rpi-3-b.dtb
[all]
dtparam=spi=on
dtparam=i2c1=on
dtparam=i2c_arm=on
dtoverlay=pitft35-resistive,rotate=90,speed=20000000,fps=20

hdmi_cvt=720 480 60 1 0 0 0

No success.

Next, detached the PianoHAT and pHAT DAC from the pHATStack.

No success.

Attached the PiTFT to RPi0W without the Stack cable.

No success.

A user reports on succesfull install with a RPi0W:
https://forums.adafruit.com/viewtopic.php?f=47&t=122926&start=45#p633546

Now this really is a tricky little display!


#10

Happy 2018!

I’ve been testing the adafruit-pitft-helper script, and learned a few things.

Started again with 2017-11-29-raspbian-stretch.img

The only way to succesfully set up the PiTFT is SSH using WiFi, NO peripherals connected to RPi0W’s USB and HDMI.
Pixel desktop appears on the display, although scaled, now it’s like 800x600 pixels (or more?), which makes everything smushy and hard to read.
Ok, there’s the desktop. Don’t even think using resistive touch!

After first succesfull install, I went hotplugging my favorite USB hub, the one with ethernet.
The display turned black and the system irrepairable. I would call this “BSoD, Black Screen of Death”.

Started over again, replacing the hub with a more generic one, and plugging in a (“Rapoo” brand) mouse/keyboard receiver. Everything ok!

Installed pHAT DAC software and rebooted.
BSoD… Desktop is gone.

Tried “other things” as well, but always ended up with a black screen, irrepairable. The system is just too delicate for anything useful.

I guess I’m done playing this game.

Fortunately, the good old Jessie based image is perfectly operational!