Pi 3 B no Wifi/bluetooth


#1

Hello Pimoroni,

I have little problem with my latest Pi3B. Wifi is not working at all. First thing i noticed when i turned on Pi for first time is that there is some barely there buzzing noise from area in between HDMI, micro usb and Display port.

I tried 3 different installation of raspbian that are working on my other Pi’s. As last resort i downloaded fresh latest image of raspbian and burned it on new micro SD. Still no Wifi and buzzing sound still there.

I plugged in USB wifi which is working out of the box.

#####################################################################################

pi@Rpi3B:~ $ sudo vcgencmd otp_dump
08:00000000
09:00000000
10:00000000
11:00000000
12:00000000
13:00000000
14:00000000
15:00000000
16:00280000
17:1020000a
18:1020000a
19:ffffffff
20:ffffffff
21:ffffffff
22:ffffffff
23:ffffffff
24:ffffffff
25:ffffffff
26:ffffffff
27:00002727
28:885207ea
29:77adf815
30:00a02082
31:00000000
32:00000000
33:00000000
34:00000000
35:00000000
36:00000000
37:00000000
38:00000000
39:00000000
40:00000000
41:00000000
42:00000000
43:00000000
44:00000000
45:00000000
46:00000000
47:00000000
48:00000000
49:00000000
50:00000000
51:00000000
52:00000000
53:00000000
54:00000000
55:00000000
56:00000000
57:00000000
58:00000000
59:00000000
60:00000000
61:00000000
62:00000000
63:00000000
64:00000000
65:00000000
66:00000000

#####################################################################################

pi@Rpi3B:~ $ cat /proc/cpuinfo
processor : 0
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

processor : 1
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

processor : 2
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

processor : 3
model name : ARMv7 Processor rev 4 (v7l)
BogoMIPS : 38.40
Features : half thumb fastmult vfp edsp neon vfpv3 tls vfpv4 idiva idivt vfpd32 lpae evtstrm crc32
CPU implementer : 0x41
CPU architecture: 7
CPU variant : 0x0
CPU part : 0xd03
CPU revision : 4

Hardware : BCM2835
Revision : a02082
Serial : 00000000885207ea

####################################################################################

Last part of of dmesg where i noticed errors. Same micro sd card on other Pi3B with working wifi does not produce these errors!

[ 1.747644] systemd[1]: Cannot add dependency job for unit regenerate_ssh_host_keys.service, ignoring: Unit regenerate_ssh_host_keys.service failed to load: No such file or directory.
[ 1.751079] systemd[1]: Starting Forward Password Requests to Wall Directory Watch.
[ 1.751421] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[ 1.751494] systemd[1]: Starting Remote File Systems (Pre).
[ 1.866015] usb 1-1.1: New USB device found, idVendor=0424, idProduct=ec00
[ 1.866030] usb 1-1.1: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[ 1.869178] smsc95xx v1.0.5
[ 1.885482] fuse init (API version 7.26)
[ 1.920267] i2c /dev entries driver
[ 1.960074] smsc95xx 1-1.1:1.0 eth0: register ‘smsc95xx’ at usb-3f980000.usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:52:07:ea
[ 2.055689] usb 1-1.4: new high-speed USB device number 4 using dwc_otg
[ 2.121423] systemd-udevd[139]: starting version 215
[ 2.187260] usb 1-1.4: New USB device found, idVendor=0bda, idProduct=8176
[ 2.187274] usb 1-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 2.187282] usb 1-1.4: Product: 802.11n WLAN Adapter
[ 2.187289] usb 1-1.4: Manufacturer: Realtek
[ 2.187297] usb 1-1.4: SerialNumber: 00e04c000001
[ 2.776291] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[ 3.680448] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[ 4.065668] mmc1: error -110 whilst initialising SDIO card
[ 4.160228] systemd-journald[143]: Received request to flush runtime journal from PID 1
[ 5.015968] usbcore: registered new interface driver rtl8192cu
[ 5.920146] random: crng init done
[ 6.367549] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 6.632607] uart-pl011 3f201000.serial: no DMA platform data
[ 7.121841] Adding 102396k swap on /var/swap. Priority:-1 extents:2 across:167932k SSFS
[ 7.205616] mmc1: error -110 whilst initialising SDIO card
[ 7.298012] smsc95xx 1-1.1:1.0 eth0: hardware isn’t capable of remote wakeup
[ 7.298263] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 8.744375] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 10.305609] mmc1: error -110 whilst initialising SDIO card
[ 13.405628] mmc1: error -110 whilst initialising SDIO card
[ 36.751286] Bluetooth: Core ver 2.22
[ 36.752074] NET: Registered protocol family 31
[ 36.752081] Bluetooth: HCI device and connection manager initialized
[ 36.752100] Bluetooth: HCI socket layer initialized
[ 36.752109] Bluetooth: L2CAP socket layer initialized
[ 36.752133] Bluetooth: SCO socket layer initialized
[ 36.767082] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 36.767089] Bluetooth: BNEP filters: protocol multicast
[ 36.767102] Bluetooth: BNEP socket layer initialized

I am wondering if i can do anything to fix this problem?!


#2

Have you tested the same OS installation with another Pi 3 successfully?

What are you powering the Pi 3 with?


#3

I am using official Raspberry pi supply 2.5A one and WD labs 3A one.

I have 3 micro SD with different install of raspbian. They all work normally on other 2 raspberry pi 3B, but give same errors on this one!


#4

you have another WiFi Adapter plugged in? in theory that should be no problem but what happens if you attach no peripherals, adds-ons (HATs) etc. Same?


#5

Unfortunately (for me) it gives same error in every possible case i tested it.

I had it connected to official display so i can see what is going on with wifi and troubleshoot it like that. I usually never connect my Pi’s to any type of display i do everything over SSH.

At the end i connected USB wifi so i can easier ssh into it and copy all relevant error messages to post here.

I have no clue what else to do. I unplugged everything. Last thing i tested is only motherboard, latest version of raspbian, logitech keyboard K400, TV and Rpi official power supply! This setup work with another Raspberry Pi 3 B that i bought from Pimoroni few months back!


#6

my understanding is that the built-in WiFi chip is connected to the SDIO interface, so the errors you are seeing seem indeed a bad omen.

I’m not sure whether a damage to the GPIO could have lead to something like that. The other possibility is that it’s a driver level issue… out of interest could you run the following on all the Pi3 where the WiFi works using the same SD:

cat /proc/cpuinfo | grep Revision


#7

pi@Rpi3B:~ $ cat /proc/cpuinfo | grep Revision
Revision : a02082

I did mention also in my first post that Pi is making barely there hissing noise from area near micro USB connector!
No speaker are connected to it and my other Pis are not making this noise.


#8

I’d contact the supplier and ask for an exchange. If you got it through us, email support@pimoroni.com and they’ll sort you out.


#9

I got it through you, thats why i posted first in pimoroni forums to get some help!