Raspbian - no wireless interface found

Hello All

I have two raspberry pi model 3B versions 1.2 that have onboad wifi and bluetooth. I have an ongoing issue where when I use a SD card with raspbian on (fresh install) I get a no wireless interface found and I can not seem to get it working at all.

I have rolled back to Stretch install to try and get this working with not luck.

In Raspbian buster I can not even get a wifi dongle working whereas in stretch it just recognizes it no problem.

There is loads of forums with this issue but none of the fixes seem to work for me.

Any one have any thoughts?

Thanks

No WIFI issues running Buster on my 4B and 3B+. I don’t think I’ve tried running it on a 3B yet though.
I do believe the 3B+ and 4 use the same or vey similar dual band WIFI chips while the 3B uses an older single band one, might that be the issue with Buster?
I’ll see if I can find one of my 3B’s and try Buster on it latter on today.

My 3b+ works fine and does not have this issues.

I am just getting frustrated as I want to use them but can not due to this issue. It is very odd indeed.

Thanks

I just booted up to a fresh Buster image on my 3B. No problems with getting my WIFI to work. This reminded me of something though. If you skipped the quick setup guide, and haven’t set you country in raspi-config, I think the WIFI is blocked from working. If I remember correctly its a recent change to Raspbian. It may be the same deal in Stretch too. I think it was added around when the dual band was added.

Yeah tried changing the country manually in the config setting and wpa_suppliant file with not success.

Ok, well I’m running out of ideas then? My Linux skills are noob level to be honest. If you haven’t already I would download a new image, reflash your card, and start over with a blank slate.
What happens if you take the working card from a 3B+ and put it in the 3B? You would have to set it up for the 2.4 GHz band first though as the 3B isn’t dual band. .