Wifi connection problems


#1

Evening all!

I’ve had a Raspberry Pi 2 for a couple of years, but I’ve virtually never taken it out of the box.

I have just bought a dongle in order to connect to the Internet, but I can’t figure out how to make it work.

Any ideas?


#2

Have you installed the latest and greatest version of Raspbian? There should be an icon in the top-right corner of the UI for connecting to WiFi.


#3

Hi Mate,
I’ve downloaded the new version of Raspbian and transferred it to my Pi using a pendrive. However, I can’t work out how to install / run it on the Pi.

If you could give me a pointer on this, I could then follow the link to access Wifi.

It’s dead frustrating looking at all these amazing projects, when I can’t get past this problem.

Thanks for getting in touch.

Alan


#4

Okay, let’s approach it from another angle. Fire up “Terminal” and type:

sudo ifconfig

And let me know what you can see. It might be that we can still get a network up and running and then update from there.

Without a network connection of any sort on the Pi, it will be tricky to do an update. I guess you’ve got code/settings/apps etc that you don’t want to lose on this Pi? If so, can they be backed up to the pendrive?

The usual procedure for updating when you’re not worried abut what’s on your SD card is to write the SD card directly. This requires a computer that can read/write SD cards and following this guide here: https://www.raspberrypi.org/documentation/installation/installing-images/


#5

We’ve hardly used it so there isn’t anything to save!


#6

Welp, looks like you at least have a wireless interface. Do you know the SSID and password of your network?

Follow this guide: https://www.raspberrypi.org/documentation/configuration/wireless/wireless-cli.md

You need to create a file at /etc/wpa_supplicant/wpa_supplicant.conf

With the contents:

network={
    ssid="testing"
    psk="testingPassword"
}

Replacing with your network details where appropriate.

And then try rebooting and see what happens.

(sudo ifdown wlan0 && sudo ifup wlan0 might also work)


#7

I have the SSID and password.

I can see where to create a file, but where you say "at /etc/wpa_supplicant/wpa_supplicant.conf

I don’t know what you mean. Sorry.

I think I had looked at the link you set earlier. But I didn’t have a clue.

Thanks for your time, please bear with me!

Alan


#8

The key points from that link (because there’s a lot of jargon in there):

  1. Open a terminal window on the Raspberry Pi as you did before.
  2. Type sudo nano /etc/wpa_supplicant/wpa_supplicant.conf and hit Enter (This creates a text file for your wifi settings).
  3. Enter the following in the text file (replacing as necessary):
network={
    ssid="testing"
    psk="testingPassword"
}
  1. Now save the file by pressing Ctrl+X, then Y, then finally press Enter.
  2. Then safely reboot the Pi.

Hope that helps!


#9

They are absolutely great instructions, with just the right amount of detail for me.

I created the text file as you described and input my wifi details. But, it didn’t allow me to connect to the Internet.
Stage 2 of your list worked fine and I have checked the SSID and password. Also, other wifi does work in the same room.

Any other ideas?


#10

I did manage (!) to download an up to date version of Raspbian on to my Pi, but I can’t figure out how to install it.

I could then follow the wifi link on Pixel


#11

Installing the latest version of Raspbian from a downloaded image file isn’t completely impossible, but it’s sufficiently difficult and risky enough that it’s probably not the avenue you want to take.

The normal update procedure, if you have a working WiFi connection, is sudo apt update && sudo apt upgrade


#12

Evening all.

I’m well pleased to say that I am now online!

In the end I decided to re-install the OS again by pressing SHIFT as it was booting up, then I followed the instructions above and rebooted and it worked first time.

Thanks for the help: I’m sure that I’ll be building robots in no time.

Cheers

AlanIMG_0252