Pirate Radio - PiZero W Can't connect to WIFI


#1

I just got a Pirate Radio…and seem to be failing at the early steps. I’ve got a working image Raspbian Stretch Lite. Followed the instructions to put wpa_supplicant.conf and ssh file into the boot folder on the SD Card. Booted the pi, and isn’t configuring the wifi or ssh. The pi boots ok’ish there are a number of fails including message about dhcpd, SSH keys fail to regenerate. If I connect a keyboard, tried to edit the wpa_supplicant.conf in /etc/… however then refuses to update the file as it says its a system file, even editing with “sudo nano…”. In the past I’ve managed to connect Pi V3 to wifi no issues so at a bit of a loss. The only thing yet to try is to boot linux VM to mount the SD card and edit the files directly, which seems a bit of overkill!!! Any suggestions??? Thanks


#2

This is curious, sudo nano /etc/wpa_supplicant/wpa_supplicant.conf should allow you to edit the file.

Be careful with your WiFi SSID- it’s case sensitive.

Could you grab a screenshot/phone camera snap of the errors you’re encountering?


#3

Hi after some investigation and leaving the Pi running for a while, started to get some block errors.
Tried a different SD card, and it booted no errors, copied wpa_supplicant.conf to correct place and all fine.
Turns out if it boots with a corrupt filesystem goes into read only hence none of the commands would work nor could I write any files.
All sorted thanks