Connecting to wifi on headless pi zero w


#1

Hey everyone,

I’m a complete beginner trying to set up my rasp pi zero w. It’s running raspbian lite (stretch).
First I was trying to connect to a 5Ghz network. Realised that was silly so tried a 2.4Gz instead!

I added a file to the boot partition called wpa_supplicant.conf containing the following:

network={
ssid=“name of network” (this contained no spaces or special characters)
psk=“mypassword” (this has a ; in it)
}

I’ve been scouring the forums for answers. As a result I tried it with and without double quotes. And with and without a \ before the ;

I don’t have a usb keyboard/mouse handy - perhaps that’s just being lazy, but I’ve kind of taken it on as a challenge now! But I do have a TV hooked up. And I’ve been scanning using zenmap from my mac to see if I can find the raspberry Pi IP address. No joy so far.

Can anyone tell me what I’m doing wrong with the wpa_supplicant.conf file?
Just in case I’m doing the scan wrong - will I see anything on the last part of the boot up dialogue that would tell me if the pi has found wifi?

Any help much appreciated :)


#2

It may well be that it needs to be named wpa_supplicant.conf


#3

My typo (now corrected). I had named it wpa_supplicant.conf. It might well be something simple like that though!