Pi5 nvme 4tb 8tb drives

Hi what if any 4tb or 8tb nvme drives work with the pimoroni nvme board?

I’m running a 4TB Crucial P3. There’s nothing in particular stopping them being used and working fine.

The only caveat is that to boot from a drive >2TB and access the full capacity, you would need to mess with the standard Raspberry Pi OS install so it uses GPT partitioning instead of MBR. This is a medium PITA.

Ok cheers for the heads up Guru. I will do a little GPT partitioning research before i purchase one.

@JJR I have a Google Doc with details of the process I used to get there. It’s rough and ready and might have quirks, but covers the essential bits to watch out for.

1 Like

Hi @guru I have a very similar issue, with Pi5 running PiOS-64 with Pimoroni NVMe Base with a 4TB Crucial P3 Plus PCIe 4.0 M.2 SSD.
Unfortunately, only 2TB are recognized when having it as boot device.
Do you have a link to your Google Doc mentioned above that can help me with some commands/context on how to proceed with GPT partitioning?
Thank you very much in advance.
Kind regards,

One Google Doc. These are very much provided on the ‘it worked for me, bro’ basis. But they should get you up and running with few-to-none side effects and give you the tools to experiment:


Thank you very much @guru . I believe these pointers will definitely get me going!
I really appreciate it!!!
Best regards!

So, if we follow your text/tutorial, we will have almost 4tb space (= ~4tb - Raspberry OS) right ?

I would like to use a part for Os/plex and other to keep my films

Thanks for your answers

@guru I can confirm that your Guide worked very well!
It gave me all good pointers for the required steps and I ended up with an SSD that boots well from a single rootfs partition that is pretty much the full SSD size (GParted reports it as 3.64TB).
Special thanks for the correct option flags in rsync, as well as the detailed information on the PARTUUID updates.
Thank you very much and please keep it up!!!
Best regards.


@guru do you think It’s possible to have a video Tutorial ? 🙃🙂🙃

I’m a novice on Raspberry Pi and I didn’t understand all the instructions. It seems a little bit complicated 😵‍💫

Thank you for your Answer

Have a good day


Did you do all of the process with Terminal or with Pi OS desktop ?


It doesn’t matter, you can also do it in a SSH session

Hi @uyan,
I had connected a monitor on the Pi5, and I think it’s easier this way.
GParted still has a command-line interface if you prefer, but it’s UI is great and this is what I used.
And from desktop, I had to perform all the rest of the commands (rsync, mount, blkid, nano, raspi-config etc) via a terminal running on the desktop.

So technically, I would think you can still do all that via a remote terminal (if that’s what you meant with your original question), but desktop is always nicer, isn’t it!

Hope this helps.


Thanks for your input @alter

May I ask you something : I read lot a things about power sequencing problem fails to wake up certain SSDs.

With Crucial 4TB NVMe SSD, how do you power this SSD ? Is the Pi give enough power for your SSD without extern power supply ?


I bought a Crucial 4TB NVMe SSD, so we will see next week.

Which problems with power sequencing? Do you have a link for read?


Great ! It will be great if you can inform us, how it works :)

I saw just rumors. I don’t know more. I see/read some comments on these videos :

Have a good day

1 Like

Thank you! I will look at the video and will test the ssd and come back with answers.

1 Like

So far I just received a X1001 for testing, but I can say now, the P3 is working with the power of the pi, and this really fast!

See here, it’s my test: pibenchmarks.com

1 Like

@mcpat thank you a lot for your feedback

Woah benchmark results !!

Did you use @guru guide ?

Thank you and enjoy your config :)

1 Like

@uyan Thank you :)

Yes I used his guide. On the other hand I also tried to backup and restore an image. But because we don’t use MBR, instead we have GPT, it’s not so easy. What I have is a image which can be “flashed” with the imager app, then you need to start gparted and accept the question with “fix”. Then a backup is also working.
less work
you can’t “flash” with imager the settings (e.g. wifi, username and password, ssh access). So this settings must be written after flashing, fixing and reboot by hand.

I test a script which I wrote, so everything should work automatically. But it will take some time.