Pi5 NVMe base no more detected

For some days the Pi5 NVMe base worked fine with a Lexar NM710 SSD 1TB as boot volume.
I’ve forced a shutdown keeping pressed the power button (as at other times) but now, rebooting, I’m stuck at boot cycle because I get the error: “M.2 PCIe HAT not detected."

I’ve tried once removed the power to reconnect the flat flex cable, but it was well fixed and rebooting I get the same error.
If I insert an SD card the system starts from there.
If I move the SSD to an external USB case I can see the volumes.
Is it a base hardware failure?

Why did you do the above? Does a double press not work?

I use it with an arch linux distro and the default behavior of double press is to logout. I used the long press when it wasn’t reachable in the network.

1 Like

Ok that explains that. If it was me, I’d start from scratch and do a full reinstall, assuming that’s possible.

Using Raspberry OS I have the same issue…

Ok, that means its likely a hardware issue. If you haven’t already I would reseat the ribbon cable at both ends.

Yes, but without success.

Ok, my thoughts are its hardware. maybe @guru can help?