PI5 NVME Base & WD drive compatability

Hi all

I see the Pimorini NVME shop page has been update with the advice
“We recommend avoiding WD drives apart from this one above (which has a Phison controller). The controller on the Green/Blue/SN350/SN550/SN850/X has proved to be incompatible”

So I have tried a WD Black SN770 and WD Black SN850X and both have issues supporting this statement. However I also have a running WD Blue SN580 that is running at Gen 3 and so far no reported errors. I know its early days and all a bit hit and miss at the moment!
I am a bit hesitant to use this a a development system now (investing time and effort), but would assume I would see issues straight away if its is really a controller compatibility issue!
Any one else have success or not with this drive ?

Many thanks and regards

@bobtrex So the story goes: These drives need the extra SUSCLK clock signal to function. If it’s not present, you see nothing and the drive sulks. Except sometimes they work. Maybe. Maybe not. Given how many drives work really well and cost relatively little, and the reported problems with the WD drives, we just recommend avoiding them until the mists of uncertainty clear. Given the extra clock is unnecessary and not provided on the PCIe connector, we’re loathe to make the product more expensive to support a specific niche of drives.

I’d be interesting in the issues you’re seeing on the drives that show up, as that may be something we do have a solution for :-)

@guru. Many thanks for the info and update. I will try to do some more testing on the WD 580 over the next few days. I agree that steering clear of WD is the best advice to offer at the moment!.
I also have a Pineberry NVME base and none of the WD drives I tested on that base would were recognized and I ended up with another Samsung 970 Evo plus.
FYI on the Pimoroni base the WD Black SN770 seemed to work ok at Gen 2 speed but would give correctable errors at Gen 3 speed. I didn’t do any extensive testing. The WD Black SN850x (4TB) was not seen on the bus no matter what I tried.
Regards

Ah, just wondering on the 4TB I just used the PI imager to prepare the drive, so I could be seeing a MBR vs GPT issue here as well!

Yeah. If you want to boot from a drive >2TB and see all the capacity, then the standard MBR format is not your friend :)

I have a rough google doc for the path I took, but I’m not sure it’s a good path right now.

No probs. Not a priority for me, I only tried the drive to help someone else on the forum who was trying to get the same drive to work! I didn’t think of the capacity issue at the time!

@guru
I notice additional advice on the shop page has appeared “Samsung 970 EVO Plus. Runs at quite a higher temp.”
I am trying out using an 8GB PI5 with 1TB Evo plus as my everyday desktop!!
Could you share what temps are you seeing and in what circumstances?
With “sudo smartctl -a /dev/nvme0n1” I am seeing 33Deg C in the desktop and up to 45Deg Copying 20GB of files to the drive!

Regards

@bobtrex This is very anecdata right now. The drive and NVMe Base felt hotter after testing than other drives I’ve been testing. I need to quantify this, and if the results are like yours, move it to the ‘good’ list.

I’ve got some more tested drives and have updated the list again. The SN770 worked well for me, the SN550 kinda worked (can’t boot from it) and the SN570 wouldn’t even get to the bootloader. I’ll try again with supplementary power later in case that changes things.

Hi. Any update on WD drives like SN850X?

It’s my point of view but they are no compatibility because SN850X is PCIe Gen4 x4
Used only PCIe Gen3 x4 like Patriot P300

in file
sudo vi /boot/firmware/config.txt
add
dtparam=pciex1_gen=3
Regards