Picade hat config


Hopefully someone can help.

I’ve just built a Picade 10” using a RP4 4GB.

Finally got it up and running but when I run the line “curl https://get.pimoroni.com/Picadehat | bash” it says “Do you want to continue?”

I reply yes and the it does a load of stuff and the comes back:-

Checking environment…
Updating apt indexes…
…E: Failed to fetch https://repo.fury.io/redraw/packages 404 not found [ip: 4431
E: Some index files failed to download. They have been ignored, or old ones used instead.
Apt failed to update indexes!

Not sure what I’ve done wrong here, can only one shed any light please?

Just to add to this, I’ve since installed a Pi 3 B+ and used bog standard RetroPie and all is working.

I was using an Arcade Punks image before on the RPi 4 and couldn’t download the picadehat drivers.

The same thing on the RPi3, the Picadehat drivers won’t install using an Arcade Punks image, anyone managed this?

Shame as they worked on my original Picade.

I have the exact same issues with the Pi4 PICADE 10in and Arcade punks 64GB childhood memories and 128GB Nostalgia releases.
Both are running Raspbian buster.

Did you every find a fix ??

Hi ixx

No I didn’t fix it in the end, I just ran with a pi3 B+ in the end and thought I’d wait until RetroPie was ready for the Pi4.

I never found the post that you did to explain how to install the picadehat drivers, very frustrating.

I ran into all the screen issues you did too lol but got there in the end.

So I’ve just read your “EPIC” instructions on how to do this.

Very well done by the way, they should be sticky but I don’t think they sticky posts on here but I think many will find these instructions helpful so thank you for your time and effort in writing them.

It’s my last day of the holidays today so I might have a go at getting the Pi4 working again as I have both images of which you speak and I also find the overlays irritating too, if you find out how to switch them of please post and I will do the same if I do.

Will I be good to go by just powering up the Picade using the USB C into the picadehat and typing in the screen res script in the console and then running the github part?