PICO LIPO not detected

a few months ago I purchased a PICO LIPO, I have just tried to us it.

When I connect to my laptop, press the boot switch and cycle power it is not detected and so does not go into boot mode.

I have tried two USBC cables the second has data and power.

Any suggestions how I can fault find?

I have soldered a header on and it looks okay.


Can you post a photo of your header soldering?

The bootloader which causes the drive to show up as a USB device is hard-wired into the RP2040 chip, so unless you’ve properly fried the chip somehow it should always work. Just to be clear, you’re holding the BOOT switch down while you power cycle the board, right? You shouldn’t release the BOOT button until after you’ve released the power button.

So I am connecting the pico via a cable to my MAC.
Make sure the power LED is Off.
Hold BOOT, press power on and then release Boot when the power led is ON.

I have just gone back to my PI4 and tried it and it has worked!!

thanks for your response.