Pico not detected with Raspberry pi ( but work with Windows)

P.S. I use Google Translate.

Hello, I just received my Pico (order # PI465090). I start by trying to connect it with my Raspberry pi 4B 8gb which is running Debian and which is up to date, while following the instructions of the official Guide “Get started with MicroPython on Raspberry pi Pico”. I held the BOOTSEL button for 3 seconds, connect the cable, release the botton and then … nothing. Nothing will happen and nothing is detected. So I tried all the USB sockets on my Raspberry Pi 4b with my keyboard and mouse. I also tried plugging in a USB key to see if it would detect and everything was normal.

I then tried to plug the Raspbery Pico into my desktop computer which uses Windows 10 and the Pico is finally detected (for information, I used the same cable as when it was connected with the Raspberry Pi 4b). So since it is detecting I Download MycroPython in Pico with the .UF2 file and Pico reboot normally.

Then I try it again with my Raspberry pi 4b and I still don’t detect anything. I looked at Forums and saw that the cable could cause a problem, so I tried 5 different micro USB cables and still nothing.

I tried running the command : ls /dev/tty*
/dev/tty /dev/tty19 /dev/tty3 /dev/tty40 /dev/tty51 /dev/tty62
/dev/tty0 /dev/tty2 /dev/tty30 /dev/tty41 /dev/tty52 /dev/tty63
/dev/tty1 /dev/tty20 /dev/tty31 /dev/tty42 /dev/tty53 /dev/tty7
/dev/tty10 /dev/tty21 /dev/tty32 /dev/tty43 /dev/tty54 /dev/tty8
/dev/tty11 /dev/tty22 /dev/tty33 /dev/tty44 /dev/tty55 /dev/tty9
/dev/tty12 /dev/tty23 /dev/tty34 /dev/tty45 /dev/tty56 /dev/ttyAMA0
/dev/tty13 /dev/tty24 /dev/tty35 /dev/tty46 /dev/tty57 /dev/ttyprintk
/dev/tty14 /dev/tty25 /dev/tty36 /dev/tty47 /dev/tty58
/dev/tty15 /dev/tty26 /dev/tty37 /dev/tty48 /dev/tty59
/dev/tty16 /dev/tty27 /dev/tty38 /dev/tty49 /dev/tty6
/dev/tty17 /dev/tty28 /dev/tty39 /dev/tty5 /dev/tty60
/dev/tty18 /dev/tty29 /dev/tty4 /dev/tty50 /dev/tty61

i thought it was hold the pico button in ,then plug in usb and let go of button

I’m seeing mine on my Pi400 running the latest PiOS.
my ls /dev/tty* near as I can tell matches what you posted above. I have to admit to not knowing what that means?
Is it not showing up in in file explorer, or Thonny, or both?

yeah sorry, that what i did, hold the button then plug. i did the test again just to be sure and still nothing. I edited the main post. thanks for pointing my mistake :)

Its not showing on both, the only place i detected the Pico is on my Windows computer.

So yeah, i’m sorry if i was not clear. My problem is that my Pico is not detected at all from my Raspberry pi 4B. And my Raspberry pi is my main platform to learn programming and Python.

If I get a chance I’ll fire up my Pi 4B and see what I can see.

My PICO is detected by my Pi4B, not sure if its a 4 gig or 8 gig though? I have a 4 gig and an 8 gig, just not sure which one this is? It’s doing updates at the moment, I’ll check the ram when that’s done.

EDIT: Its a 8 gig.

Second EDIT: I was seeing it in file explorer after booting it with the boot select switch held down, but it was MIA in Thonny. I had to do an apt update apt upgrade to update Thonny and see the PICO in the Interpreter options.

Thank you, i tried a fresh intall of Debian yesterday too and it didnt change anything. i’ll write an e-mail to Pimoroni.

I just receive an email saying they are shipping me another one! I just wanted to keep you updated and thank you one last time for the time you took to answer me :).

When you say “fresh install of Debian” do you men the PiOS version?
And if not 32 bit or 64 bit?

I just made a discovery ! i think the problem coming from my mouse and keyboard ( maybe taking too much current ? )

If I remove my mouse and keyboard, my Raspberry Pico get detected by my Raspberry Pi 4b 8Gb ! I tried with only the keyboard plugged, it worked. Then i tried with only my mouse plugged and it worked again, the Pico got detected. But when i plugged the mouse and keyboard, nothing happen when I plug the Pico.

For information my mouse and keyboard are :

  • mouse- ASUS ROG Spatha (current 5V, 500mA)
    -keyboard- Razer Deathstalker (current 5V, 350mA)

I hope it help someone else !

850ma is a fair bit. The max for USB on a Pi 4B is 1.2A.
FAQs - Raspberry Pi Documentation