Pico Lipo 16 MB is somehow working somehow not

Hello 🙋‍♂️,

I just received a new Pico Lipo 16 MB and thought of trying out an “older” program I wrote in Circuitpython. I’ve put the newest Circuitpython pico lipo version on it, copied a lib file and the code.py onto it and it didn’t run.

Since I wasn’t sure if the pico or the old LED strip was the problem, I tried another LED strip that also didn’t work. I then tried another pico with the same two LED strips and with that other “older” pico everything worked quiet fine.

I thought maybe the Circuitpython Version is the problem and loaded the same version with the same code on another pico Lipo, to see if this other pico lipo works with the LED strips and it did.

Just to be sure, I then loaded the latest micropython on the “new” pico lipo and tried to run a unicornpack and it didn’t work. I tried to do the same with the “old” pico lipo and everything worked just fine.

So the pico somehow always appears as a USB-Device and I can run simple stuff like print("Hello World") in Circuit- and Micropython, but for some reason I can’t run more complicated stuff that uses periphery.

Has someone seen such a case before and/or has any idea how to solve this?


Check your soldering.

I checked that first. It looks quite fine to me.
Also, it’s strange to me, that the pico just stops working whenever I start one of these “more complicated” files. If it would just work and answer via the REPL in a normal way, with the LEDs just not lighting up, I’d also think that it’s the soldering, but since it becomes unresponsive, I have the feeling that it might be something different.