Pico Display pack stopped working

Hello,

I’m quite new to microcontrollers, so let me know if I missed some information in my description.

I recently purchased a Pico Display Pack along with a Pico with pre-soldered headers.

After running through some of the MicroPython examples to get familiar with it, I decided to switch to CircuitPython as I wanted to use the USB HID libraries, which I don’t believe are supported in MicroPython yet.

I got it working using wildestpixel’s code, which use the ST7789 drivers. It worked, and I got to work modifying it for what I wanted to create - a universal mute button for Zoom, Meet and Teams.

However, after a few days of messing around with it, the display appears to have stopped working. It looks like it’s on, but doesn’t display anything and doesn’t return errors. The LED still works. I even tried going back to previous MicroPython code, and that also no longer works.

So my questions are:

  • Could I have permanently damaged the Pico Display by using CircuitPython and the ST7789 drivers?
  • Is there a way to reset the Pico Display to see it can be revived?
  • What’s the simplest code to verify if it still functional or not?

Thanks in advance for any help!

Did you use the flash_nuke.uf2 to clear the memory before putting the latest Pimoroni UF2 into the Pico?
It will totally clear the memory. I would try that first. Then a simple “Hello, World!” to the screen.

Best of luck

Thanks for the super quick response!

Yes, I’m pretty sure I tried that, but re-tried it now for good measure. Still seems to be the same problem, code runs but display stays blank - although backlight is on.