Pico Display Pack 2.0 - Blank Screen/No Output


Trying to run the micropython examples for the Pico Display Pack and I’m not having any luck actually outputting anything on the display.

I’ve tried firmwares 1.18.7 - 1.19.0 with their corresponding rainbow examples pasted into Thonny (no package errors), edited for the Pico Display 2.

The LED does the hue rotation, the backlight on the display turns on but nothing is drawn.

I’ve tried with both the Pico and Pico W, no joy on either.

It’s my first time using the Pico, but absolutely not my first embedded device or programming rodeo.

Any help is appreciated.


1 Like

It looks like the examples haven’t yet been updated for the new Pico Graphics.
The st7789 goes and is replaced with

import picographics
from picographics import PicoGraphics, DISPLAY_PICO_DISPLAY_2

display = PicoGraphics(display=DISPLAY_PICO_DISPLAY_2, rotate=270)

pimoroni-pico/README.md at main · pimoroni/pimoroni-pico (github.com)

I had some working examples but I’ll be darned if I can find them just now?

Thanks alphanumeric.

I’ve tried both the st7789 and the picodisplay libraries, from the tags on the releases (so the examples should match the firmwares) and neither seem to work with my display :(

I’m thinking its a hardware fault. If it was software you would have gotten a “no module named st7789” etc error message. It’s what I get if I run old code on 1.19.0.

There is a contact support link on the main shop page you can use to e-mail Pimoroni Tech support directly. You likely won’t get a reply until Monday.

Contact Us for Raspberry Pi Technical Support - Pimoroni

1 Like

Thanks again, I’ll get on that.

I think I’m having the same problem and it’s possibly some hardware fault; I found that if I press the bottom of the screen upwards (USB port on the left, for reference) I do get some output, but as soon as I stop pressing the display start to glitch and then blanks out.
Did you have any luck with the tech support?

Did you solder your headers yourself? Sounds like it might be a poor connection somewhere?

No, it’s happening with a pre-soldered pico. Only thing I can think of other than a fault is that I wasn’t careful enough fitting the screen onto the pico…

You are cautioned to only press on the circuit board when attaching it to a Pico. Same deal with the Pi based GPIO displays. It’s not so easy to do in practice though.