Pico inky not working

Hi, I recently bought Pico inky pack, but I can’t get it to work.

I am using pimoroni-picow-v1.19.15-micropython.uf2.

Added all files from the examples folder, the .py files are running but the display doesn’t change see below:

Sorry to hear that! Some things you could check:

  • Is the Pico plugged into the pack the right way round (there should be USB markings on the underside of the pack to guide you).
  • Is the Pack fully pushed down on the Pico’s header pins?
  • If the Pico header is one you’ve soldered yourself are all the pins making good contact?

I’m also not able to use the Pico Inky with a new Pico W.

Using pimoroni-picow-1.19.7-micropython.uf2, the Pico W is running some test code just fine (urequests, LED on/off, that kind of thing), but when I plug it into the pack, it never becomes available on USB (Thonny can’t find it), and it never runs main.py (blink test code).

At least in my case this was… headers? I had purchased two Pico Ws, and when I soldered the other, it worked fine. Ug… now to debug soldering work

The most common things to look for are pins where the solder has formed more of a ball around the pin; it wants to look more like a volcano sat down on the PCB ;)

If you’re struggling to spot the problem, post some (in focus!) pics of it and folks here may well be able to spot the offending solders.

Good hints! I think it was just one header, towards the top left of the board (pin 3, IIRC). Re-soldered it, Re-flashed, and now it works!

Hints gained over many years of my terrible soldering - glad to hear you’re up and running!