Pimoroni Pirate Radio - FWD Button doesn't work


I received my Pirate Radio yesterday. I have soldered the pins in the rpi zero w and the pins in the phatbeat. So I have powered on the Pirate radio, even created my own customized playlist and everything worked as charm except the fast forward button.

So in order to tackle this issue i have dissembled it once again and tried to re-solder the BCM 5 ( Physical Pin 29 or Wiring Pi pin 21). Unfortunately the fast forward button still doesn’t work.

As an effort to further investigate on the problem, I have installed the piggpio tool in order to perform further diagnostics and the following (truncated) table has be retrieved from the “gpio readall” command.
It shows that the Pin GPIO.21 even though is IN has 0 Voltage.

±----±----±--------±-----±–±Pi ZeroW-±–±-----±--------±----±----+
| BCM | wPi | Name | Mode | V | Physical | V | Mode | Name | wPi | BCM |
| 5 | 21 | GPIO.21 | IN | 0 | 29 || 30 | | | 0v | | |
| 6 | 22 | GPIO.22 | IN | 1 | 31 || 32 | 1 | IN | GPIO.26 | 26 | 12 |
| 13 | 23 | GPIO.23 | IN | 1 | 33 || 34 | | | 0v | | |
| 9 | 24 | GPIO.24 | ALT0 | 0 | 35 || 36 | 1 | IN | GPIO.27 | 27 | 16 |
| 26 | 25 | GPIO.25 | IN | 1 | 37 | 38 | 0 | ALT0 | GPIO.28 | 28 | 20 |
| BCM | wPi | Name | Mode | V | Physical | V | Mode | Name | wPi | BCM |
±----±----±--------±-----±–±Pi ZeroW-±–±-----±--------±----±----+

Apart from that I have also checked with the short-circuit setting of a multimeter shortage between the Ground and the Pin GPIO.21. And guess what it is shorted to ground. However I believe I didn’t do anything wrong during the soldering and this behavior was present from the beginning.

I would appreciate any help since now i am changing stations only via the VLC Media Player web interface http://IP_Address:8080/ .

Thank you!

Best Regards,

Pressing the rewind button should also change channels / stations. It just goes the other way in your list.
Did you solder all the pins on the Pi and pHat Beat? And do you have your own buttons wired up or are you just using the ones on the pHat Beat.
pHat Beat pinout is here

Pictures of your soldering, Pi and pHat beat might help.

No I have used the default pHat Beat buttons, no custom buttons. Also yes I am using the reverse to perform the change but it is a little inconvenient.

By the way here are the pics.

Could it be a bad soldering?


Also that particular pin is grounded even without the pbeat hat attached in the rpi.

Fast Forward is GPIO 5, physical pin 29
GPIO 21 is physical pin 40
Both of these pins have a ground directly opposite them Pin 30 and 39 are ground.
Look for any solder bridging the gap between pin 29 and 30, and pins 39 and 40.

I can’t make any sense out of how wiring pi labels the pins?


Well according to the https://pinout.xyz/#phatbeat the BCM5 = Physical pin 29 = Wiring Pi pin 21.

Do you have any clue what could be wrong here?
Maybe a seemingly cold joint or something else? Also without connecting the phatbeat shouldn’t I have V=1 int he BCM 5 as the other GPIO pins?


Do you have a multi meter handy? If yes I’d measure the resistance of Pin 29 referenced to ground. If it measures 0 ohms its shorted to ground. A cold solder joint would leave it open, as if it wasn’t soldered at all. If thats the case it would measure as a very high impendence / open circuit.
If you accidentally left a solder trail from one pin to another, like say pin 30, that would explain why it shows as a low 0. It would be shorted to ground.
I can see some solder between the rows / pins in your picture. I can’t tell if its enough to short trwo pine together though? Not from that picture. A close up straight down picture of pin 29 and the pins around it might help.

Hey There.

I have just measured the resistance between the pin 29 and pin 30 and it is 0 ohms. Please also find another new image attached.

Can’t see much from that new image. It appears that PIN 29 is shorted to ground. It’s either damaged or its shorted to another pin my a solder bridge. I think you need to carefully clean up any excess solder blobs around pin 29.

Well i have cleaned the board with alcohol and took measurements again. No change. I have started thinking if the short-circuit is inside the plastic of the color coded header. But this is impossible isn’t?

I doubt its a short in the header. More likely something is broken on the Pi itself. The chip that controls that PIN likely has a fault in it. What caused it is debatable. It could have been like that from the get go or the result of a static discharge or overheated by soldering.
IMHO you need to replay that Pi with one that works if you want full functionality of your Pirate Radio.