Pirate radio / Phat beat - power button stops working


#1

Hi there,

I have built the Pirate radio and installed the pimoroni script for using it as internet radio.
Athough it’s my first soldering project and also the first raspbian project, it seems to work well.

But I noticed, that after some time of playing (I think at least 30-60min), the power button stops working. All other buttons and the radio itself still work fine. This behavior is reliably repruducible.

I have used the newest raspbian stretch lite (kernel 4.14) and executed the script (curl https://get.pimoroni.com/vlcradio | bash) to install the vlc radio.

How can this be solved?


#2

The on / off button uses GPIO 12, PIN 32. Double check your soldering on that PIN. Also have a look at the physical button to make sure its not broken etc.

Just covering the basics, but if it works then doesn’t work, it does sound like it could be software.


#3

I’m running the full Raspbian Stretch, just personal preference. Once I’m done with my setup I just set it to boot to command line instead of the desktop GUI. That’s the script I ran on mine, I’m not having that issue. I run mine for hours before turning it off. All the other buttons are OK? Just confirming you tried all of them, play pause, channel up down, volume etc.


#4

Initially all buttons are ok, including the power button. But after some time, the power button exclusivly doesn’t work.

Button itself and soldering look normal.


#5

If it was me I think I would redo my SD card from scratch. It sounds like a software issue. Your the first I’ve heard with this issue so My guess is your install is corrupted some how?


#6

I already reinstalled the whole system, which did not change anything. Maybe a new bug, that has appeared with a rasbian update?


#7

Did you redownload Raspbian to get a new image? I’ll keep an eye on mine I use it quit frequently, and I usually have it on for several hours.


#8

Good point. I have always used the image, that I had on my hd. Next time, I’l download a new one and compare the hash.


#9

Also how old is the SD card your using? If you have a spare it couldn’t hurt to use it.


#10

Software-wise the power button is handled in the same way as the other controls:

It issues a sudo shutdown -h now command to your system. It’s possible this command is running and failing perhaps?

All of the VLC control is logged, so when you press the button and it doesn’t work it might be worth checking:

tail /var/log/phatbeatd.log
tail /var/log/phatbeatd.err

To see if any result from the “Pause” command is returned, or any errors have occurred.


#11

Problem is gone, after I prophylactically resoldered all pins. So, it seems, the reason for the issue was a cold soldering joint, which lost connection, after it became warm after hours of playing.


#12

Hay, nice going, glad you got it fixed.