Pirate audio / mopidy Can't find local files

Relative Noob (owned various pi since 2012)
Trying pirate audio amp with mopidy to use as home made ‘boombox’.
My mopidy Iris can not find the music I have placed in /pi/home/Music
I have searched around on mopidy forums
Installed twice
Now using June 2020 raspbian as posts from this time imply working systems.

Had just come across a fix for this from another forum post. https://forums.pimoroni.com/t/pirate-audio-mopidy-setup-issues/13138

The command “sudo mopidyctl local scan” mentioned in the getting started guide was not working, was getting this sort of error:

$ sudo mopidyctl local scan
Running “/usr/bin/mopidy --config /usr/share/mopidy/conf.d:/etc/mopidy/mopidy.conf local scan” as user mopidy
usage: mopidy [-h] [–version] [-q] [-v] [–config FILES] [-o OPTIONS]

unrecognized command: local

More specifically, Mopidy-Local does not appear to be bundled in by default anymore (looks like it was in older versions)

Fixes - install the local extension

sudo python3 -m pip install Mopidy-Local

Edit the config file /etc/mopidy/mopidy.conf

sudo vi /etc/mopidy/mopidy.conf

Add these lines (adjust the path for your pi)

media_dir = /home/pi/Music

Restart service

sudo systemctl restart mopidy

Try the local scan command again

sudo mopidyctl local scan
1 Like

Thank you so much
that worked perfectly
I should add for the benefit of those that follow, in Iris you need to click the cloud icon in the top right when looking for files and ensure Local is ticked, when you refresh you will see your music.