Pirate Radio newinstall with raspbian 11-29 and oneline installer


#1

Hi,

I made a new install using RaspBian-11-29 and used an apparently updated oneline installer for vlc-radio.
It works (both Full and Lite versions), but I cannot get it to play my own internet radio streams. It seems the filestructure has changed from my first installation some three-four weeks ago, and I cannot locate the right default.m3u file containing the playlist. Where should I search ? I found one default.m3u in /Pimoroni/phatbeat/projects/vlc-radio/vlcd/etc/vlcd containng a playlist, I edited that to suit my radiostreams but after reboot the device anyhow doesnt play according to my own playlist. What to do ?
Thanks in advance
calleblyh


#2

What I’ve been doing is putting my SD card in a reader and plugging it into my Windows PC. Then I copy my playlist.m3u to the root of the partition that shows up. Boot I think. Then when I boot up my pi that playlist gets moved to and replaces the default playlist. I know where the actual file is, but would have to boot up that Pi with a monitor to get the path correct to post here.


#3

Do you still get the pop sounds when changing channels? VU meter working OK? I ask because I’m still running Jessie on my Pirate Radio. If the pops are cleaned up I’ll redo it with Stretch.


#4

Thanks for returning. Still no success getting my own playlist to work. VU meter working after checking advices according to https://gist.github.com/Gadgetoid/3301cec3e47495e75b31d3120d8f17d9
There is some cracklin towords the end of the boot process. After a very short test changing channels I have experienced pops and cracks
All for now, continuing tomorrow


#5

Try sudo nano /etc/vlcd/default.m3u


#6

Thank you very much. That made my day.


#7

Good stuff, enjoy your tunes.