Pirate Radio Kit not working

Hi

I purchased the Pirate Radio Kit over xmas and I have installed it according to these instructions:

https://learn.pimoroni.com/tutorial/sandyj/internet-radio-on-your-pirate-radio

I am using the latest version of Raspbian Lite and have done sudo --update and sudo --upgrade

I have tested the PhatBeat and it works based on the examples provided and I can hear audio being played through the test WAV file however nothing plays when VLC Radio is installed. Pi was rebooted. There was this error during the install ‘apt failed to install vlc-nox’. I did manually install VLC and trying to install vlc-nox it came back and said to try vlc-bin which I did.

When I try to check the list of radio stations config file there isn’t a file located at:

/home/pi/.config/vlc/playlist.m3u

So assume VLC Radio did not successfully install??

Best Guess is its a VLC versus Buster issue? It might even be because your using the Lite version. There appear to be some things missing in the Lite version of Buster that were in previous Lite versions of Raspbian. Thats the impression I get.
I’m still running Jessie or Stretch on my Pirate radio. It’s working fine so why fix what’s not broken etc.
One option is to install Buster with Desktop. Do all your setup etc and then go into Raspberry Pi configuration and set it to boot to command line. It’s what I did. I like doing things from the GUI versus command line. I can also just clip and past the commands from a browser into the terminal, no typo’s etc.
If that still doesn’t work you could try Stretch instead of Buster. You can get it here.
http://downloads.raspberrypi.org/raspbian/images/

great and thanks for the info!! I managed to get it working with [2019-04-08-raspbian-stretch-lite.zip]

http://downloads.raspberrypi.org/raspbian_lite/images/raspbian_lite-2019-04-09/2019-04-08-raspbian-stretch-lite.zip

Ah, thats good to hear. The only current Pi model that has to run Buster is the Pi 4B. Any other version just will not boot on it. I probably should have mentioned that, I guess I just assumed you were running a Pi Zero W. Anyway enjoy your tunes. My Pirate Radio gets used a lot on weekends. I like my classic rock.

cheers!!

Also according to installation article to edit the station playlist the file should be located in:

/home/pi/.config/vlc/playlist.m3u

I could not find it and doing a search in Terminal the only .m3u’s which are coming back are located in two folders. To work out which m3u playlist was correct I did a test checking the actual station playing on my Mac and it appears the correct location to edit the list of stations is actually at:

/etc/vlcd/default.m3u

sudo nano /etc/vlcd/default.m3u Is what I have in my crib sheet for pirate radio.
You can also just copy your playlist.m3u file to the fat32 boot partition on the SD Card on a PC.
When the Pi boots up it gets moved to the correct location and becomes the new default playlist.
This will erase all the presets though. It’s what I do as I only ever listen to a couple of stations.