Pirate Radio - pHAT BEAT [Discontinued]


My rusty old Pirate Radio was working until my SD card got corrupt few days ago.

So looking around it looks that the Pirate Radio is not on offer anymore so is the pHAT BEAT :(
now replaced by Pirate Audio range. Shame.

So I have 2day tried to re-install.

I have used the latest image:
Raspberry Pi OS Lite
Release date: October 30th 2021
Kernel version: 5.10

Enabled SSH, and Wi-Fi done update/upgrade and run the script:
curl https://get.pimoroni.com/vlcradio | bash

But I got several errors and the Radio is not working anymore :(

First was about missing wiringpi

wiringpi is required
Installing wiringpi...
E: Unable to locate package wiringpi
Apt failed to install wiringpi!
Falling back on pypi...

So I fix that with:
cd /tmp
wget https://project-downloads.drogon.net/wiringpi-latest.deb
sudo dpkg -i wiringpi-latest.deb

Second was I think bit more complex and I have tried few things (install pHAT BEAT on its own and then vlcradio) but none of them works and my Pirate Radio is now not working :(

checking for wiringPiSetup in -lwiringPi... no
configure: error: You need libwiringPi installed

Installing Pi VU Meter...
make: *** No rule to make target 'install'.  Stop.

All done!

Press Enter to continue...

--- Warning ---

The VLC Radio installer
does not work on this version of Raspbian.
Check https://github.com//
for additional information and support

Some changes made to your system require
your computer to reboot to take effect.

Would you like to reboot now? [y/N] y

So at the end it says “The VLC Radio installer does not work on this version of Raspbian.” so is that the end of the Pirate Radio? Or does/will it work only on Buster (OLDSTABLE/Legacy) image?

I’d say for now, its use Buster not Bullseye. I really hope my pHat Beat doesn’t break as It’s basically the center piece to my custom Pirate Radio build.

Last night I have tried the OLDSTABLE
Raspberry Pi OS Lite (Legacy)
Release date: December 2nd 2021
Kernel version: 5.10
And it still works :)

But the question is will it work on the latest (STABLE) image in the future?

Why is the pHAT BEAT missing from the website?
is giving 404

You can get older images / releases of Pi OS here.
Index of /raspbian/images (raspberrypi.org)
The pre legacy version of Buster is there.

I would say the pHat Beat is now discontinued. And only available with the Pirate Radio kit, as long as supplies last. Once those kits are gone that’s likely it for the pHat Beat.

That’s how it looks to me anyway.

Let’s see how the guys from pimoroni.com will see it, will they still support the product after the sell by date …

have you check pimoroni’s gitHub page
GitHub - pimoroni/phat-beat: Python library for PHAT BEAT - A stereo DAC, AMP and VU for the Raspberry Pi

I have a VEML6075 UVA and UVB Sensor breakout, the product page is gone but the Pimoroni github repository is still there. I have downloaded it to my PC just in case. Same thing for the pHat Beat.
On my Windows PC I just click the green code button and download zip file.

I don’t think we’ve any plans to discontinue Pirate Radio, but we are having difficulty making up more kits at the moment because of Pi Zero WH supply problems.

I replied to your other thread but posting here as well in case it’s useful to others - I believe there have been changes to wiringpi in Bullseye which is probably what’s causing problems with the installer. There’s a related Github issue to track here: wiringpi not available on bullseye · Issue #38 · pimoroni/phat-beat · GitHub