Pizero W Octocam - Newbie - Where do I start?


#1

Have bought one of these kits for my son who is eager to get into learning about the pi.
Followed the assembly instructions no problem but when it came to software, I found myself instantly out of my depth.
How do I get it to operate as a camera? do I need to install the operating system on it first?
Does the program have to be put onto the SD card via my mac or through the raspberry pi?

Thanks in advance and sorry for such a basic question, there just doesn’t seem to be a quick step by step guide for what to do here.
Cheers.


#2

This video will guide you through all steps required to setup your raspberry pi :
https://www.youtube.com/watch?v=PijX8GDco-g&t=126s
Note that you can use a micro sd to sd adaptor instead of the usb micro sd card reader.
Useful links:
etcher.io
raspberrypi.org/downloads
By the way, welcome to the raspberry pi community!!
All the best,
Karan


#3

They just released this tutorial here which should hopefully help

https://learn.pimoroni.com/tutorial/sandyj/motioneye-os-on-your-octocam


#4

That’s great! Thanks. The tutorial helped a lot!
Up and running with it now. Just trying to work out how to use the camera over the internet rather than just within the local network.
Cheers.


#5

To do that, you could forward port 80 (the port used by motionEye OS) on your Pi’s IP address. You’d do this through your router admin (usually accessible at http://192.168.0.1 on your local network, otherwise look underneath your router and the admin URL will probably be there).

If you just want access to the raw video stream, then you can forward port 8081.

The other option is to use a service like ngrok, which will set up a secure tunnel to your local machine.


#6

I was thinking about the security side of exposing it to the internet after finishing mine tonight. I guess the built in security is pretty weak if I were to just forward the ports and enable basic security on the stream?

Would you recommend ngrok for the best security?

Also no big issue but I thought I might as well flag it. Etcher just would not work for me on Windows 10 so I used my usual (Win32DiskImager). I kept getting a weird error after launching the process. I am sure I have used Etcher on Linux just fine though.


#7

Can someone help me with Wireless access for the Octocam. I have followed the instructions “to a point”. I intend to build the Octocam with my son so I did a dummy run. I followed the instructions on how to put the raspberry pi image onto the SD card and then I using a Windows 10 computer I created the text file on the SD card to enable wireless access called “wpa_supplicant.conf”

update_config=1
ctrl_interface=/var/run/wpa_supplicant

network={
    scan_ssid=1
    ssid="TP-LINK_F41CAE"
    psk="xxxxxxxxx"
}

I then boot the pi without plugging the camera in, yes it is a standalone pi as I assume the camera not being present will not make a difference, I want to leave this for my son.

I am using a TP Link wireless access point and I have also tried my Samsung galaxy as a hotspot.

In both cases I cannot get the Pi Zero to connect to either of these wireless networks.

I have created the text files in Notepad, Notepad++ and Atom on the same windows 10 machine that I used to burn the SD card. As far as I know I am saving them as raw text files so Carriage returns and Line feeds etc should not be an issue or is there something else I am missing or do I need a Linux machine to create the text file or some other form of encoding?

Thanks in advance.


#8

Hi mark when I set mine up on windows 10 I used notepad++ and in save as I switched it to “all files” and saved it with .conf on the end and it worked first time.

I used my router software to watch for the new device coming up and it only took a few minutes. It did take longer for it to come up with the host name though (this was watching from the bt home hub software).

As you have a visual link to the device it should be much easier to see when it does obtain an ip address.


#9

… and you seem to have a screen hooked up, I’m going if you have a keyboard you can attach too, try to create it with nano right from within the booted Pi. Then issue the following:

check that you have a

try with a simplified wpa conf file like so:

network={
    ssid="TP-LINK_F41CAE"
    psk="xxxxxxxxx"
}

you shouldn’t need anything else in it to establish a basic connection.

… and since you seem to have a screen hooked up, if you have a keyboard you can attach too, try to create it with nano right from within the booted Pi. Then issue the following:

sudo ifdown wlan0
sudo ifup wlan0

#10

I take it this is a Pi Zero W that you’re trying it on?

It’s also worth noting that it will get stuck in an endless reboot cycle if it can’t connect to a network, hence @RogueM’s suggestion might not be possible.

I’d suggest starting afresh. Re-image the SD card, create the wpa_supplicant.conf file again in Notepad++, and see if that sorts things.


#11

Dear All

Thanks for your help. I downloaded a new image from the motionEyes website and it worked first time.

I also tried it with the verbose conf file and a short version of the file and no difference, both worked.

I tried saving the file as a txt and as a Unix bash script and try as I may I could not recreate the error I had previously.

If in doubt rewrite the image

Cheers

Mark