Plasma 2040 bootloader

Hi. I received my Plasma 2040 a couple of days ago and haven’t been able to get it to enter bootloader mode by holding Boot and pressing Reset. I’ve tried 3 different USB-C cables in multiple USB ports of 2 PCs - Windows 10 and KDE Neon Linux. Any ideas?
I’ve had no trouble getting my Pi Pico to enter bootloader mode by holding Boot then connecting.
Thanks,
Ben.

Hi MCMBen,
I haven’t seen the schematic for this board. So this is a guess. The reset is equivalent to powering up where the processor looks to see if the Boot button is pressed. If so it goes into boot mode. There is no reset button on the pico, so that is why they say hold down the boot button when plugging in.
Try just holding down the boot button whilst plugging in the c connector. As you might do with a pico, instead of pressing the reset button on this board.
If it does come up in boot mode, it may be some link you need or something else.
Worth a try?
PeeWee1

Thanks @PeeWee1 , I have also tried that, to no avail. I’m assuming the reset button is essentially the same as the Captain Resetti button you can add to the pico - effectively powering off then on instead of using cable removal.

Hi MCMBen,
I agree on the reset theory. Which does pose the question is the hardware faulty?
Re your C cable connector, I think if it works on other devices it does suggest it’s not that.
Aside from looking at the board for anything obviously unsoldered or short circuited you would be best to raise a support ticket on email to Pimoroni. If it’s new and it’s never worked it could be a QA problem.

I don’t own a Plasma, but I do have a PICO with a Reset button added.
With it powered up I can
Press Boot & Reset,
then release Reset
then release Boot
and it goes into boot loader mode, no having to unplug the USB cable.
Just a FYI post.