MicroPhyton on Tiny 2040

I have a tiny 2040 board. I’m trying to change the firmware to Microphyton like I have done with with a standard pi pico board but the boot button isnt working the same.

Am i missing something?

No issues here with mine. You didn’t maybe mix up which button is which?
With the USB Jack up, Boot is on the Right and Reset on the Left.
Press and Hold Boot, press and release Reset, release Boot.

Thanks but that’s not working for me. I hadn’t tried using the reset button like that as i was trying to replicate the usb plug in like the the standard board!

I have two tiny’s a 2mb and an 8mb both of which aren’t connect like my standard pi pico. I’ve tried on my home pc and my work laptop!

I’m now very confused!

Holding down the Boot Button while plugging in the USB cable should work? It works for mine. Have you tried more than one USB Cable? It needs to be a power and data cable.
So, no Pi RP2 showing up? Any error messages?

Good call on the cable. I have only one usb c cable which came as a charger so it might be a real rookie error!

Amazon are shipping me a proper data cable tomorrow! Fingers crossed!


Cable arrived yesterday and now everything works as expected.

I didn’t realise that power only usb c cables existed.


They do, and even proper cables can break internally and render them power-only (or worse!).

The life expectancy of USB cables in my car is measured in weeks :-)