Problem installing Automation HAT Python library

I followed instructions provided here:

First I tried automated install. While it did do quite a lot of things it also reported some errors:
pip-3.2: error: No command by the name pip-3.2 list
(maybe you meant “pip-3.2 install list”)
Unable to install RPi.GPIO for python 3!

But if I try running ‘pip-3.2 list’ on the command line it works fine.

Later the execution completelly stops at the step where it is asking if I want to install complete package with examples.

Then I tried manual setup with
sudo apt-get install python-automationhat
and got:
E: Unable to locate package python-automationhat

I then installed sources manualy using zip file from github.
When I try running an example
sudo python
I get:
Traceback (most recent call last):
File “”, line 5, in
import automationhat
File “/usr/local/lib/python2.7/dist-packages/automationhat-0.0.4-py2.7.egg/automationhat/”, line 50, in
i2c = SMBus(1)
IOError: [Errno 2] No such file or directory

Any ideas what is wrong and what I can do?

What version of Raspbian are you running? What do you see if you run: lsb_release -a?

I have similar issue for python 3 with raspberry pi 4 and raspbian buster
I solved it by Turn On I2C interface in Raspberry Pi Configuration
and sudo pip3 install smbus.

I reply this old thread for documentation and just in case anybody face same issue again.