Problem with Pico Unicorn Pack

I got my headered Pico and Unicorn Pack in the mail today.
Eager to try it out I learned how to build the C/C++ examples from Raspberry Pi and blink worked like a charme.
So I moved on to the unicorn pack and set up the pimoroni-pico sdk. I went ahead and build the unicorn example. I moved the uf2 file to my pico with the unicorn pack connected. It disconnected but nothing happend. The LEDs did not light up.

So I figured, that I made a mistake of some kind. So I went ahead and installed the custom micropython from pimoroni. Working with thonny I tried to run the script. But the LEDs didn’t light up either. :(
Strangely enough the test of the button worked ( promts you to press the A button and prints a message when it is pressed).

I have absolutely no idea what went wrong. Is my unit just broken?

Did you try the Rainbow example?
pimoroni-pico/micropython/examples/pico_unicorn at main · pimoroni/pimoroni-pico (

1 Like

Yes, I tried it but didn’t work either :/
I even tried an older release of Micropython
So I think it’s safe to say that some part of it is broken
Sadly I don’t have the knowledge and equipment do find out what

It does sound like something is borked? Some good info here and a function reference.
pimoroni-pico/micropython/modules/pico_unicorn at main · pimoroni/pimoroni-pico (

Or contact Pimoroni via e-mail and see if they will replace it. I’d put a link to this thread in that e-mail.
Contact Us for Raspberry Pi Technical Support – Pimoroni