Propellerhat not working!


#1

hi,

Got the propeller hat today. Installed on Rpi - jessie.

IDE installed and it can compile program. Unfortunately, when I try to download, I get error.
SoI tested with p1load and it gives

./p1load blink.binary
(LOW).
Failed to open export for writing!
Failed to open gpio17 for writing!
Failed to open gpio17 direction for writing!
error: can’t find a port with a propeller chip

any help is greatly appreciated.

–a thomas


#2

p1load is pretty crusty now, the latest Propeller IDE uses propman.

Have you tried:

sudo propman blink.binary

I’m looking into the state of Propeller IDE and raising some issues. It seems to have gone off the rails for the Raspberry Pi- this may be because I haven’t been working as closely with the maintainers as I did previously.


#3

Hi,

Thanks for replying. Here is what I get with propman.

$ sudo propman blink.binary
pm.loader: [ttyAMA0] Preparing image…
pm.loader: [ttyAMA0] Downloading to RAM…
pm.loader: [ttyAMA0] ERROR: Download timed out

-athomas


#4

hum, it’s been a very very very long time I haven’t toyed around with the Propeller but are you not supposed to specify the reset pin?

sudo propman -p 17 blink.binary

#5

I dusted my trusty Propeller tonight and all works fine with propman here.

In a nutshell, I installed the Propeller IDE 0.36.7, the latest version pre-compiled for the Pi and used some binaries made from some of the spin examples found in the propeller-hat repo. As stated, worked like a charm.

As with anything relying on serial communications, there’s a number of pitfalls you should be aware of:

  1. serial console should be disabled
  2. if you are on a Pi3, the ‘proper’ serial bus has been hijacked by the bluetooth gods

To ensure you get those 2 out of the way, run:

curl -sS get.pimoroni.com/uarton | sudo bash

… I’ve also put together a one-line installer specifically for the propeller-hat but I’m still refining it. Still, if the above does not solve the problem, hold tight, there should hopefully be a simplified way to get going in short order!


#6

Hi there,

So I ran your script. Just to be sure, I reran and now I get this

=============
This script will enable the serial console login!

— Warning —

Always be careful when running scripts and commands
copied from the internet. Ensure they are from a
trusted source.

If you want to see what this script does before
running it, you should run:
\curl -sS get.pimoroni.com/uarton

Do you wish to continue? [y/N] y

Serial console enabled

================

I still get the error as before.

$ sudo propman -p 17 blink.binary
Using GPIO pin 17 for hardware reset
pm.loader: [ttyAMA0] Preparing image…
pm.loader: [ttyAMA0] Downloading to RAM…
pm.loader: [ttyAMA0] ERROR: Download timed out

appreciate your help to get me going…

thanks
–athomas


#7

I take it from the output that you are not on a Pi3?

what is the output of:

propman -v

and what about:

propman -l

#8

i am on rpi3. Will send you the outputs you asked for later today (when I get home).


#9

hum, it sounds like the uarton script did not pick up on the fact that you are on a Pi3…

could you run the following for me:

curl -sS get.pimoroni.com/cpuinfo | bash

and post the output here.

either way, then the likelihood that you are using the mini-uart is almost certainly the cause of your trouble. Try adding the following line to /boot/config.txt:

dtoverlay=pi3-disable-bt


#10

Sorry should have made it clear earlier. The script did pick it up. The first run it did modified my config in the boot dir. What I sent earlier was the output of running it the second time.


#11

are you fitting the HAT directly onto the GPIO? if not post a picture of your setup.

Last thing that comes to mind is that, actually, I don’t think you should run propman with sudo… I don’t know if that could cause some issues but I’m going to try at my end to see if that can be a factor. It is certainly not to be ruled out.


#12

no, it seems to be OK either way here, however it would be interesting to know whether propman throws the same or a different error if ran without elevated privileges.

Incidentally I am assuming you are logged in as the Pi user, not as root, or a custom user that would not be part of the dial out group?


#13

Here is the output you requested.

pi@rpi3:~/pgming/propeller propman -v FATAL: The application binary appears to be running setuid, this is a security hole. Aborted pi@rpi3:~/pgming/propeller sudo propman -v
PropellerManager CLI 0.36.7
pi@rpi3:~/pgming/propeller $ sudo propman -l
ttyAMA0

In my case, without sudo, it does not work. I am not logged in as root. Also attaching the pic.


#14

Hi RogueM,

I am all set now. I had taken the hat out yesterday and then connected it incorrectly.I fixed that and it is working now. In terms of setup, I think it was disabling the bt that was the key.

My request would be to update the doc on github from

dtoverlay=pi3-miniuart-bt

to

dtoverlay=pi3-disable-bt

Appreciate all the help.

–athomas


#15

ah, yes, I can see it in your first picture now that you pointed it out!

either overlays will do the same thing as far as the UART switching are concerned, though repurposing the mini-uart to bt has very little value in most cases.

still, I am not sure why your system frowns upon propman having the setuid flag, that’s not expected behaviour, on raspbian at least - have you by any chance ran rpi-update to roll (knowingly or not) an experimental kernel?

EDIT: mystery solved - I see that the learn portal still has instructions relevant to Wheezy, which I suspect you did follow.