Propeller not detected


#1

I followed the steps from the IDE getting started but when I try to run my project I get this error message when I leave as AUTO:

Error is : No such file or directory
error: opening serial port ‘AUTO’

or this one if I select /dev/ttyUSB99:

error: hardware lost
error: no propeller chip on port ‘/dev/ttyUSB99’

Am I missing some step? I disabled serial in raspi-config and executed

sudo ln -s /dev/ttyAMA0 /dev/ttyUSB99

Thanks in advance.


#2

Did you reboot after disabling the serial?


#3

Did you install the modified version of p1load included in the repository? ( https://github.com/pimoroni/propeller-hat/tree/master/software/p1load )

The next release of the IDE should eliminate a lot of the frustrating fiddling and hacks needed for the loader.


#4

I did install the modified version of p1load but I was getting error messages related to it in the IDE. I tried to reinstall it but the script would fail because the file was already there. I deleted the file and reinstalled it using the script. It succeded but now I get the missing port messages.
I did reboot and now the ttyUSB99 doesn’t show up in the drop down. It appears again after I recreate the link.
Any guess on the next IDE release?


#5

I don’t have a Pi or Propeller HAT with me today, but could you try firing up LXTerminal and running something like:

p1load -g 17

I seem to remember there being a version string for p1load which might help debug it.

You can also try the Python loader to verify it’s a software problem, try:

sudo pip install p1
sudo python -m p1.loader version

Hopefully we’ll get to the bottom of this! It really bugs me that Propeller HAT isn’t as smooth sailing as I’d envisioned… yet!

As for the IDE, hopefully soon. I might download an earlier version of the source and build up a temporary version that shows /dev/ttyAMA0 in the port list and installs the patched loader automagically. I had such a thing working locally, and still do, so I often forget the experience isn’t quite as finished for everyone else yet.


#6

The next IDE release is imminent. Brett Weir ( the guy behind it ) has been incredibly busy making it more awesome- and we’ve just got a Pi version built and working.

Now available here, version 0.30.1: http://developer.parallax.com/projects/propelleride/

You will also need to do this after install:

sudo chown root:root /usr/bin/propman && sudo chmod 4755 /usr/bin/propman


#7

I’ll give this a go!


#8

After upgrading, I had to change the path to the compiler and the loader in the IDE preferences and then it worked.
Thanks!


#9

Brilliant! I’ve been catching up on Propeller recently and am planning some new tutorials- more to come if you don’t just dive into the Object Exchange and soar ahead of me.


#10

I am getting this using the p1 loader:

pi@Rpi ~/Propeller $ sudo python -m p1.loader upload -g 17 ./LEDtest.binary
Parallax Propeller Loader

Modified 2015 by Phil Howard
Original © 2007 Remy Blank

Traceback (most recent call last):
File “/usr/lib/python2.7/runpy.py”, line 162, in _run_module_as_main
"main", fname, loader, pkg_name)
File “/usr/lib/python2.7/runpy.py”, line 72, in _run_code
exec code in run_globals
File “/usr/local/lib/python2.7/dist-packages/p1/loader.py”, line 562, in
exit(args.action(args))
File “/usr/local/lib/python2.7/dist-packages/p1/loader.py”, line 474, in _action_upload
args.serial, version = detect_port(args.gpio_pin)
ValueError: too many values to unpack

… that is not the modified p1loader, just straight from pip.

That said I’m only posting in case it matters to you, as propman works for me:

pi@Rpi ~/Propeller $ ./propman LEDtest.binary
Using GPIO pin 17 for hardware reset
Connecting to ‘ttyAMA0’… [ DONE ]
Downloading to RAM… [ DONE ]
Verifying RAM… [ DONE ]

Incidentally I found a way to install just propman with a limited number of dependencies, and no IDE on my prototype machine… once I figured out all the bits and pieces for optimal protocol using a separate IDE workstation I will contribute a walkthrough, although that might have to wait until I am finished soldering the other 62 points on the HAT header ;-)


#11

all works nicely using propman. However a tiny bit annoying is the fact that the serial connection seems to sit in a state of lazy wait, and the first attempt always fail with:


Connecting to ‘ttyAMA0’… ERROR: 9
[ ERROR 9 ]: Device unexpectedly disconnected!

same if I send another propman command more than a few seconds after the first. So essentially I always have to try 2 times before successful upload.

Not sure if there is a standard way to wake the serial device that I could use as pre-command to propman?


#12

OK, I think this is an issue with propman, or at least I find something that seems related:

on the other hand it sounds to me that he’s only probing for Pi2 ARM_V7 or am I reading it wrong? I’d comment on that commit but since I’m a big noob I’ll wait for master Phil. As know all things he does ;-)


#13

yep, master Phil all things he knows… always one step ahead too!


#14

Not sure this issue is fixed- yet- it’s not something I’ve come across, but propman definitely likes to hang in places. It’s a brand shiny new loader, though, so it’s likely a little rough around the edges, and in the middle.

The “Too many values to unpack” error is the Python Propeller Loader failing in a horribly non graceful way.


#15

Looks like Brett has been doing a lot of stuff to the propman repo today… sadly still no Makefile so I can’t test (haven’t figured out how at least, I’m at best mediocre at anything that involves a compiler).

On other news though I managed to compile the latest openspin on my headless pi and it works a treat. So now, I can touch up my spin code from the coach… does life gets any better than this?


#16

Have you tried running qmake against propman? Might work, I can’t say I’ve tried compiling it on its own yet!


#17

yes, just was reading up on qmake after seeing the .pro file that looked suspiciously similar to a MakeFile… will have a go.


#18

nope, not out of the box:
Unknown module(s) in QT: serialport

… so it looks like I need an extra deps just for building? this is on the machine I have the full IDE with all the deps you recommend on the github btw.


#19

after some detective work here is what I found:

  • QT serial port introduced with QT5.1
  • not included in the ‘Essentials’ modules

My QT is at 5.2, so I guess the problem might be with the wheezy backport of QT5 that may not have been compiled with the add-on modules.

ah, well, patience is a virtue they say, I’ll wait for the next drop of the IDE and copy propman over.


#20

I think libqt5serialport5 was listed as a dependency to GitHub, but not the dev library.

Try:

sudo apt-get install libqt5serialport5 libqt5serialport5-dev