Raspberry Pi 2- What works and what doesn't!


#22

So, so bright! Do not look into PiGlow with remaining eye! Have fun!


#23

Hi,

Don’t want to nag, but I’m keen to get my Pi 2 + Dot3K up and running, any updates on the available of a P2 compatible RPi.GPIO, please? :-)

Thanks.


#24

As I said in the post, there will be no update to RPi.GPIO until the patch it depends upon is properly tested and released with an updated Raspbian firmware.

You absolutely can install a pre-release RPi.GPIO and get your Display-o-Tron up and running today, just like KingScooty has above, but I’m not shouting about that method because it may cause other problems.


#25

Thanks for the update. I shall be more patient ;-)


#26

HI,

Just out of curiosity, what is the bug and patch that is causing and resolving the RPi.GPIO issue?

Ben


#27

I’m not sure what the wider problems with RPi.GPIO are, I think there might be some that I don’t know about.

The bug I discovered, however, is that high-resolution timers are not enabled by default with the current Raspbian release. The result of this is chaotic- basically anything that relies on (approximately) precise timing will see all of its delays rounded up to about 20ms. So a loop of 1000ns delays running 1000 times will run for 20 seconds instead of 1 second.

As for the PWM/Interrupts, I don’t know if there’s another fix for these but it seems like it. The latest is:

All unit tests now pass for RPi.GPIO 0.5.10 - on both RPi1 and RPi2. You have to be running correct firmware for PWM.

— Ben Croston (@CrostonBen) February 12, 2015

#28

Thanks for getting back so quickly. Looks as if the wheels are in motion.


#29

Even more good news, it looks like an updated firmware package might be imminent:

@CrostonBen excfellent! I'll be updating the firmware deb later today

— Alex Bradbury (@asbradbury) February 12, 2015

#30

Seems like good news!


#31

Aaaannnd we have an update! See the update above for information on how to get your Pi 2 up to date with the latest firmware/kernel and RPi.GPIO!


#32

Alas, still no Unicorn HAT. Still, we live in hope!


#33

Yep. Gutted no working Unicorns yet, I’d be most grateful if it can be fixed.

So far I have a bad experience with my second Pi:
I bought a Pi2 because lots of comments said it was much improved in GUI mode (and it is!) however I bought it with a Unicorn HAT which it appears won’t work. (Hoping it is fixable!)
Also despite the Pi2 dimensions being identical to my B+ it won’t fit in my previous (circa August 2014) Ninja PiBow case (layer 3 sits proud due to a couple of components being in the way).
Another issue is that the Unicorn HAT won’t fit in my PiBow case (because layer 5 would cover some of the LEDs) but I heard there were issues with the Unicorn and PiBow so this was my fault for taking a gamble.

(Edit: Due to issue with the Unicorn and Pi2 I have refitted my B+ into my PiBow case and the only issue is that layer 6 sits proud because the plastic behind the USB and Ethernet ports won’t fit around my Unicorn HAT, leaves 1 or 2mm gap between layers 5 & 6. In all fairness I have been offered a replacement layer with my next order. Thanks Pimoroni!)

Like the Bounty ad “I’m just waiting, anticipating…”

Craig


#34

Hi,

I updated to get my dot3k working, starting with a fresh installation of Raspbian (NOOBS 1.3.12).

However, the examples wouldn’t work, apparently giving an SPI error, and i2cdetect also failed.

I googled, and found the suggestion to comment out the blacklist entries for these, but on this version of Raspbian, the files to edit are not there.

However further googling uncovered the [new?] way to enable these interfaces, which is,

sudo nano /boot/config.txt

and add these two lines,

dtparam=i2c1=on
dtparam=spi=on

After doing this, and rebooting, my dot3k is working! w00t! Thanks to everyone who contributed.

More detail here

Nigel


#35

The new style PiBow cases will fit both the old B+, the new Pi2 and the Unicorn HAT. Unfortunately we couldn’t have predicted the changes to the Pi2, and making that troublesome layer forward-compatible is basically impossible. Layers that don’t route that intricately over the top of the board are basically too fragile to be worth sending out.

However, we do now sell the replacement layer for the Pi2, and it’s only £1 at present: http://shop.pimoroni.com/products/b-pibow-upgrade-layer


#36

@Snips I have updated the dot3k magic installer to set these device tree settings. So the next time you install a fresh Raspbian image you can get Dot3k up and running, and examples downloaded, with just:

curl https://get.pimoroni.com/dot3k | bash

#37

Hi, i need some more help! I have just re installed raspbian by mistake and i cant seem to get piglow to work anymore. please help!


#38

Try this:

curl https://get.pimoroni.com/i2c | bash

#39

Thanks for replying so quickly! I’m so sorry you have to put up with me!


#40

Also. Is there a way to restore my old raspbian os instead of using the clean version that i accidentally installed?


#41

NO IM sorry. I’m getting this

Traceback (most recent call last):
File “arm.py”, line 10, in
piglow = PiGlow()
File “/usr/local/lib/python2.7/dist-packages/piglow.py”, line 26, in init
self.bus.write_i2c_block_data(0x54, 0x00, [0x01])
IOError: [Errno 5] Input/output error