Raspberry PI3 and 7" LCD Touch screen not powering up


#1

Hello experts!
I have a setup involving a CraftBeer PI card mounted on a Raspberry PI3 card and a Raspberry 7" LCD Touch screen.
I´m trying to use 2 power sources, because one is not sufficient to run the whole setup.

The Craftbeer PI card requires 12V/5A and it has an adjustable stepdown “buck” that is set to deliver 5.1V to the Raspberry PI below. The CbPi card/RbPI is powered via a MDR-60-12 transformator (see pictures).
The screen is attempted powered via another MDR giving 5V/3A.
However, the system/screen is not powering up/booting.
Does anyone have an idea of what I´m doing wrong here?

PS! I have measured Volts & Amps using a multimeter.


#2

Double check you have the ribbon cable going from the Pi to the display the right way up. Get it backwards/upside down, and nothing happens.


#3

I found out that I had made the rookie mistake to copy the NOOBs folder with files in it to the SD card, instead of just the files on the root ;). The FFC cable is placed correctly and I was able to boot now.
My next issue is that I cannot get it on the WIFI. I´ve done the sudo nano … stuff and set my network credentials according to a Youtube video, but the PI cannot see the network after this.
I can see that the network uses WPA2 Personal, so maybe the key_mgmt parameter should be WPA2-PSK instead of WPA-PSK…? Or maybe something else must be done, that you know?


#4

Raspbian lite? I’ve only ever done it manually via edit once, don’t remember if it worked or not now though? It was a while back. I ditched the lite version for the full version, I just find it easier to set things up, like WIFI. Then when I’m all done, I switch it to boot to command line instead of desktop.
If your running full Raspbian just click the WIFI icon in the tray, select your network, etc.


#5

Nope, full desktop version of Raspbian. I used the NOOBS version 2.4.5 to install.


#6

If it’s just the normal WIFI setup/connect, just click the Icon in the tray, etc. You need to wait a little while after first boot up though, or no networks will show up. Takes a minute or two or three for detected networks to show up. That throws a few people off thinking it isn’t working. Just be patient.


#7

I´m not sure if I understand what “icon in the tray” you are talking about? I see a desktop with a trashcan. And by going into the Raspberry menu (top left), I can go to user settings and Raspberry PI Configuration. Under the tab Interfaces I can see many disabled functions that I can activate on the PI (SSH,VNC,SPI…) but no WiFi…
In the top right corner on the desktop I can see a disabled bluetooth icon and a disabled wireless interface icon. These cannot be clicked. I saw that I could edit the WPA_SUPPLICANT.CONF file with my network credentials and reboot, but that did not do the trick either…


#8

For me it’s right next to the Bluetooth Icon over by the clock. Two diagonal red X’s with bars attached


#9

Yes, I know. The problem is that this is inactive ;). I must be missing a package or maybe I need to start a service… however, I´m not sure what and how


#10

OK, not sure why its off, unless something else has reconfigured things. I do believe the Bluetooth WIFI uses one of the Pi’s serial interfaces, UART. And swaps the one sent to the GPIO with the Mini interface. Something like that. Does your other board use the serial interface? Pins 8 and 10 on the GPIO.


#11

Interesting! I´m not quite sure I understand what “swaps the one sent to the GPIO with the Mini interface” means, but the card I have on top of the PI i certainly occupying pin 8 and 10. I´m not sure if it is using it, but it might interfere something. I guess the only way to figure that one out is to detach the CraftBeer Pi card and power the system alternatively…?


#12

I tried to find a good link to what I was referring to, but so far have struck out. The Pi has two UARTS. A MINI and a full, best I can describe them. Before the Pi 3B the full function UART went to the GPIO pins. With the 3B, they used the full one to interface with the Bluetooth WIFI chip, to keep it off of the USB bus. That means that the MINI UART now goes to the GPIO pins. What I was thinking might have happened, was the UART driving the WIFI chip got taken over by your add in card. I could have it all wrong, way to early in the morning for this stuff. I’ll have another look see for some good info to back up, or dismiss, what I think might have happened.


#13

Found this, https://www.raspberrypi.org/documentation/configuration/uart.md
I’m not 100% its your issue, just that you should be aware of it. You may have to poke around in config.txt and see how the UART is set up etc.


#14

I have now teste the system without the extention board and there was no difference. That rules out the option of UART interruption. I´ve seen some threads about the SD card and that a “to fast” card can cause problems in loading of neccesary files, services or others… I have formatted a FAT32 version of a 32GB micro SDHC card according to NOOBS descriptions. I.e. I´m not using the standard, pre installed Raspberry 16GB card.
Raspberry Standard SD Card
Can this be a plausible reason?


#15

When you tested without the extra board attached, did you also go back to a stock Raspbian install? The software setup for the board would be what changes the UART configuration, if that’s the issue.

I personally don’t use NOOBS, I prefer to use the stock Raspbian image. I use etcher to image my Micro SD cards. I haven’t had any WIFI issues doing it that way. Two Pi 3B’s here and 4 Zero W’s, WIFI works on all of them.


#16

I´ll explore using Stock Raspbian image. Not sure if I can use Etcher on mac, but if not I´ll find an eqvivalent. Thnks!


#17

Have a look at this,https://www.raspberrypi.org/documentation/installation/installing-images/mac.md
https://www.raspberrypi.org/documentation/installation/installing-images/README.md
https://www.raspberrypi.org/downloads/Raspbian/