Retropei won't boot properly after picade x hat installation

I have a Picade X-Hat connected to Raspberry Pi 4B, in a self built arcade machine.
I followed the instructions in Assembling your 8" or 10" Picade with PICO-8 and and ran the Picade Hat installer. When rebooting, I don’t get the Retropie logo screen, but instead a rectangle with blurry colors, followed by the reboot messages (all with OK label), and ending in entirely black screen, from which I can only get to the console by F4.
This is the second machine I am building, and I think I had this issue also in the first one, but I cannot recall how I solved it.
I would highly appreciate any help.
Best regards,

I have the same problem… Total noob… anyone help?

I’ll +1 this.

I have a Picade console and the same problem. The installation works up until after the Hat Bash script. After script installation the Pi hangs on a black screen. Before having done the Hat bash script, the Pi had booted to the PiCade configuration screen.

I’ve attached the final command line screen before the screen goes blank

Thanks so much for the help.

and here is the color screen Yonatan mentioned:

I have the same problem,anybody find a solution?

Also having exactly the same problem. Anyone managed to solve this?

I am having the same problem… Need a solution please? Can anyone help?

Try this.

It sounds similar to the first of the two problems I hit, which I’ve just written up here: RPi4-based Picade Retropie Installation Issues - Solved!