Picade hat and Emulationstation not working together

Hello,

I have a newly built Picade 10 inch with a Pi 4b and am trying to get it to work using a 32GB or 64GB SD card.

With a fresh Retropie 4.6 image on the card (tried this a few times) I can connect to wi-fi and install the Picade hat. At this stage if I just turn off the machine and turn it back on again, Retropie/Emulationstation runs but the arcade buttons and joystick are not recognised at all. If I type reboot in F4 command mode then Retropie/Emulationstation doesn’t load - I get a blank screen - but in F4 mode the joystick and arcade buttons are recognised.

Any suggestions for fixing this? Thank you.

(BTW Matt from Pimoroni has been brilliantly generous with his time in helping someone as inexperienced as me get this far. Thought I’d try the forum rather than continuing to bother him.)

I have added the hdmi_force_hotplug=1 line to the bottom of config.txt and the problem persists. I’ve also tried running install.sh from a clone following these instructions https://github.com/pimoroni/picade-hat.

Here is my config.txt https://pastebin.com/uJV0RLiz

Everytime it reboots or I try to launch emulationstation, the rainbow square screen shows and none of the usual menus load. F4 still works.

Thanks for any ideas or suggestions.

Solved it! The answer was to undo the console/joystick panel in order to change the HDMI port being used on the Pi. When facing the Pi from the joystick, it should be in the left not right HDMI port.