Round2.1 touch not working - dev/i2c-11 missing

I am working with an rpi4 and a Hyperpixel 2.1 round running buster.

The display works great.
When entering the command to get touch working:

cd hyperpixel2r-python/examples/
sudo python3

I continue to get the error:

FileNotFoundError: [Errno 2] No such file or directory: '/dev/i2c-11'

Going to /dev I have i2c-22

I tried to make a link from /dev/i2c-22 to /dev/i2c-11
The touch worked great. However when I reboot the link disappears and I lose touch.

When I try to make a hard link it says I do not have the permission.

Any help is greatly appreciated.

Thank you!

With the caviet of “I don’t have a hyper pixel and haven’t tried this” you could modify the underlying library to use 22 instead of 11.

If you look at line 155 of hyperpixel2r-python/ at master · pimoroni/hyperpixel2r-python · GitHub

change it to:

touch = Touch(bus=22)

Based on line 10:

There are also some tips on creating links at the end of the page here: Getting Started with HyperPixel 4.0