RPi3 plus Zero Lipo not powering up


#1

I simplified my setup right back to the basics.
I have a RPi3, Zero Lipo soldered on. That’s it for now.
Running it headless. I plug in a 500ma lipo battery, fully charged via adafruits mini charger. Checked the batteries out put and it’s a shade over 3.7v.
The zero lipo lights up blue LED, and flashes red led. So it has good voltage, but I believe it’s warning that battery is running low?

The RPi 3 will not boot. Just a green flashing LED on RPi. No red LED. I measured across pins for 5v and ground, but only see 3.6v.

So question is… Have I fried the zero lipo when soldering the board on?

What can I check…
Or… I dunno is there a jumper to allow back powering or something?

Thanks N

Sorry note it works fine from normal USB power to the RPi. N


Zero LiPo: Unable to boot zero w
#2

… I assume you have no peripherals attached, besides a wifi adapter (or is it hooked up to your network via ethernet)?
Can you post a pic of your zero lipo fitted onto the Pi? Also, full specs of the lipo battery if not bought directly from us.


#3

Hi and thanks for help.
No peripherals at all. Just running onboard WiFi on RPi3.
I’ll get a photo now. Specs after. N

Note red slow flash, blue solid, green flashing.


#4

Battery:


500ma size.

Simply only bought this else where because of the DPD delivery costs!


#5

At the link the JST connector looks different to the connector on zero lipo? But that doesn’t seem to be the problem


#6

let me check with the engineer (as soon as I can spot him at his desk), he might be able to tell where the fault is by judicious testing of voltages across the board.


#7

Thanks all. Yes the connector was different. And I did splice it the the one provided. Cannot imagine this an issue?

I don’t think I cooked the zero lipo board. Never have before, but anything is possible!


#8

No the JST connector doesn’t seem to be the problem.


#9

Hi!

A fully charged LiPo should measure at around 4.2V, 3.7V doesn’t sound right. 3.7V is normally the nominal voltage for LiPos, measured when the battery is half full. That said, the Zero Lipo functionality doesn’t sound right either, the low battery warning light should stay on constantly when the battery is low.

It’s possible that a 500mAh battery couldn’t source enough current to run a Pi 3 without the voltage dropping 3V, where the Zero Lipo would turn off until the battery voltage soon bounced back to about 3.6 volts, where it’d turn back on. At least this would explain the blinking led light. Another option would be a faulty Zero Lipo. Have you got another battery (or other about 4V voltage source) to try it with?

Also, please remember to be careful with the polarity on 3rd party batteries, as the Zero Lipo doesn’t have reverse polarity protection.


#10

Threw the battery on charge as I did measure it after a bit of testing before. It shows 4.09 on a cheap multimeter. So while I think the voltage is alright, I think probably a cheap ebay battery and current issue like you say.

Not got another power source unless I fudge some batteries together. I might just have to fork out for one of your batteries and hope for the best.

One other note… I’m getting a high pitch squeel from zero lipo when battery is in. Kind of like a fast high pitch modem squeel.

So. If I’m running RPi3, Explorer Hat Pro to two micro motors. Is lipo or lilon a bad choice? Other nice sized alternatives that’s not a USB battery pack?


#11

Either pack type would work. I’d recommend a 2000mAh or higher capacity, as the Pi and the motors in total would draw close to 1.5A from the Zero Lipo 5V output, so current draw from the battery would be over 2A. With a larger battery you’d have a longer runtime too, a 500mAh battery would be flat pretty fast under such a load.

The high-pitch sound might be from the Zero Lipo boost converter turning on and off. If you have an oscilloscope handy, you could check the Pi 5V line to see how it looks like. Normally the boost converter switching frequency is 2MHz, far far above the audible range.


#12

Now that I checked the datasheet, at low current draw the boost converter can switch in audible frequencies too, but that would mean that the Pi wasn’t drawing current, which would be quite unlikely unless there was something broken…


#13

Thanks, i will order a Lithium Ion Battery and a new Zero Lipo to test this all - but only when you get stock back!!!

In terms of the sound it makes - it is very similar to the sound of a phone charger when the phone is fully charged!
Unfortunately i do not have a scope, or anything lab based - not since school and uni!

So, idea - which is probably bull.
The Pi will not pull current unless it sees the right voltage right? Therefore, could the zero lipo see enough voltage to turn on “bounce” voltage drops, zero lipo cuts out “bounce”, the Pi did not see 5V long enough, so no Pi red light, no current draw, whine, loop again?
If this is the case - then battery is logical… If not the battery, then perhaps i cooked the zero and its not converting to 5V correctly.

N


#14

Hi!

I tested this with some extra resistance on the input and got the exact same result that you’ve been seeing and hearing, with high-pitched whine and all. Thus, assuming the Pi is OK, I can safely say that either the internal resistance of your battery, or the resistance of the battery wiring is too large to keep the input voltage from going down to 3V and the zero lipo turning off.

Here’s the same on a scope, the yellow line being input voltage and the blue one output voltage.


#15

…and when shopping for batteries on eBay, it’s a good idea to select the seller well. Often you don’t get what’s being advertised:


#16

Hi Niko,
Thanks for the reply - it would look like you say a crappy battery from Ebay - i’ll know for sure when your Lipo Zeros come back in stock and i order that with some different batteries. I’ll provide feedback after that too.
Thanks again, N


#17

To confirm here - battery was the issue.
Slipped in a 2200mAh Lithium Ion Battery Pack and it all worked a charm, no whining.