Zero LiPo: Unable to boot zero w


#1

I have used the zero lipo before with success, however today it started to act strange and the zero will no longer boot. It works fine without zero lipo attached, and fed through the regular USB micro connection.

The blue led indicating good battery on the zero loop board is on as normal. The green led on the zero blinks irregurarly. Here’s a video showing the behavior: https://drive.google.com/file/d/0Bz8mguxaS8ubZnZSS0g0a1hLMGs/view?usp=drivesdk

As you can probably hear, theres also a high pitched noise coming from the zero lipo or from the zero itself. This noise is not present when connected to regular USB power.

Any ideas?


#2

Hi!

The Zero Lipo is oscillating between on/off: When the Zero Lipo starts drawing current, the input voltage drops below the undervoltage shutdown level and the Zero Lipo shuts down. When it shuts down and stops drawing current, the input voltage rises again, and the Zero Lipo will start again. This fast on/off oscillation is what you hear as the high-pitched noise.

The voltage drop at the input is most likely caused by the resistance of the battery wiring you’re using, give it a try using shorter and/or thicker wiring. If that doesn’t help, check out the battery too, many of the batteries on eBay don’t live up to the advertised spec, as was the case here for example: RPi3 plus Zero Lipo not powering up


#3

Thanks alot for the reply! That sounds very reasonable. So the high-pitch oscillation noise is a clear indication that something’s not right?

You are right about the battery likely being a lousy one, but I also tried using three 18650 in parallel, and also using a genuine panasonic 18650. All fully charged and with the result on all.
I made two videos testing current and voltage:
https://drive.google.com/file/d/0Bz8mguxaS8ubdklPdm9hQmNwNGs/view?usp=drivesdk
https://drive.google.com/file/d/0Bz8mguxaS8ubeklPQkNwdHp6UVk/view?usp=drivesdk

My multimeter is a cheap one so I guess it is to slow to be of much help in this case.

I tested using thicker wires (the croc cables you see in the video) connected directly to the jst on the zero lipo, still the same results.

Do you have any more ideas? 😃


#4

Hi!

The multimeter is showing average voltage, so if the battery is at >4V and the multimeter is showing down to 3.6V, the voltage can easily drop to below 3V for a very brief moment, enough to cause the Zero Lipo to turn off. Some of the cheaper croc cables are actually using very thin conductors too, AWG28 or so. I’d still reckon the problem is too much resistance somewhere between the battery and the Zero Lipo, just not completely sure where…


#5

Hi,

I’ve nearly the same problem. Zero - W start booting fine but when try to start WLAN the Zero reboot.
I tried it with Battery and also with a power-supply. See video:

When powering Zero-W with USB Power (for exampel powerbank) it boot fine.

BR
–Manuel