Raspberry pi keeps resetting during boot with LiPo shim

I have a raspberry pi zero w that works fine with direct power supply but doesn’t boot with LiPo Shim.
I see the color gradient and then the boot sequence resets. Sometimes I see the Raspberry OS screen saying “Hold shift for safe mode” but only for a second and resets right away again.

I have checked the battery voltage, both 5V and 3.3V look good. There’s no schematic so I don’t know if any other pin is doing anything to force reset.

Any ideas would be helpful.

Header soldered on?
What rating etc battery are you using?

Yes, the header is soldered on.
It’s a 3.7V, 1200mAh battery (LiPo Battery Pack – Pimoroni)

I would think that battery is enough, assuming its fully charged?
EDIT: the specs say
Maximum Continuous Discharging Current 1200 ma, which should be enough for a Pi Zero. Anything else plugged into / connected to that Pi?

That’s what I thought, it should be enough. and it’s fully charged.
Nothing connected yet. Planning to put an IR sensor but it’s just the Pi right now.

I don’t own one just so you know. I do have several Adafruit Power Boosts that do the same thing. I haven’t run into your issue. Mine are powering Pi Zero’s. Big beefy 3 cell 3300 MAH battery though as I have a Unicorn Hat HD and LED Shim attached.

My gut feeling is a hardware fault issue?

So I tried another battery and that seems to work fine.
Might have been battery discharge due to a short while connecting or something. I’m charging the battery to see if maybe the battery is faulty or was not actually fully charged.
Thanks for your help.

That’s good and bad I guess. The LIPO Shim is OK, but your battery may not be?
Does the battery that works have a higher MAH rating?

The batteries are same rating and were bought together.
The other battery was charging overnight but still doesn’t work so I’m just going to toss that battery I think.