Wide input shim doesn't power the Pi


#1

Hello there. I recently brought the Wide Input Shim to power a Raspberry Pi Zero straight from a 12v car battery. At first glance it seemed to work. When I connect it to the battery (which is currently at 12.4V), it puts out 5.01V between the 5v and ground pin, as you’d expect. However, when I connect that to the Raspberry, it doesn’t boot. And upon further investigation the voltage on the 5V pin drops to 0.54V as soon as I connect the Pi to it. Am I missing something here? Or have a received a faulty shim?

The Pi works and boots fine through usb. The car battery, although old, happily seems to output at least 1.5A on other circuits that I can plug it in to.


#2

Hooked up like this?

Did you solder on the female header or solder it right to the Pi Zero? If soldered right to the Zero, its not touching the Zero etc is it? Other than the GPIO pins that is?


#3

Yes, that is one of the ways how I tried it, the shim directly on the Zero. It was not touching he Pi. Also tried it separately with just the wires going in between. It’s 5 volts until it connects with the Raspberry and then it just drops.

Although I haven’t actually soldered it on yet until I am 100% sure it works. But I made sure it was making proper contact.


#4

Sounds like it may be defective? I don’t have one myself. If it was me I’d solder on the female header, just to be sure your getting a good connection. Then if it still doesn’t work, hit the Shop link at the top of the page. Then go to the bottom and look for the “contact us” link. That will let you e-mail Pimoroni with the issue. I’d also put a link in that e-mail to this thread.


#5

I know I should solder it eventually, but I have tested the connection in multiple ways (not just only by directly placing it on the Pi). I need to keep access to the I2C, 3V and ground pins which I still have to figure out how to do, hence why I don’t want to do anything permanent yet.

I have acquired a fresh new battery. And it is doing the exact same time. It almost makes me wonder if it is shorting or something, but my multimeter doesn’t register any amps being drawn at all from the battery. The Raspberry is fine when I test it with the usb supply so that’s not the problem either.

So my conclusion is then a broken shim :( I’ll be contacting Pimoroni.


#6

If you mount one of these, https://shop.pimoroni.com/products/protozero with a stacking header, between the Pi and the input shim, it will get you access to the GPIO pins. All nicely labled. I’ve used them in several projects to get access it i2c etc. There is a bigger Proto Hat that I’ve also used in a few projects where I used pi A+'s instead of Pi Zero’s…


#7

Can you post a photo showing how you’re connecting it, please?