Scroll pHAT - IO error


#1

hi chaps, im getting IO error in my python shell upon running scripts for the scroll pHAT,

althought everything seems to be working fine? any ideas?


#2

It’ll generate an odd IO error with no ill effect. How frequently do you see them?

The library is still a little rough around the edges, but we’ll polish it up and squelch those messages soon!


#3

hiya, i get them every now and then. its doesnt seem to be causing a problem?


#4

I’ve now squelched them out of the library, however if more than 10 IO errors occur it will pop up a little message saying so.

I didn’t get any while holding the board against a pin header manually ( no soldering at all ) so I assume it’s either flaky soldering in some cases, and an overly high brightness causing some intermittent signal noise in others. Either way it doesn’t matter- the script is resilient enough.

I haven’t pushed the update to Pip yet, but if you want to test the latest and greatest you can install the library like so:

git clone https://github.com/pimoroni/scroll-phat
cd scroll-phat/library
sudo python ./setup.py install

#5

ok many thanks, ive install the latest now. maybe the soldering is the problem, ill have to get another zero and scrollPhat to verify that! for now it seems im not getting anymore IO errors!

heres my current project im working on (updated code in the comments)
http://forums.pimoroni.com/t/twitter-hashtag-to-scroll-phat/1609/5


#6

i can confirm that ive not seen an IO error since updating. many thanks my little pirate friends!


#7

Just wondering if getting the odd IOError is normal? I added a print where the IOError exception is caught so I could get a better understanding of how many I am getting. I ran the example progress.py script for 10 minutes and caught 9 IOError exceptions.

Just wondering if this is just a thing that happens or if I should touch up the soldering on my scroll pHAT. I was originally running it on my pi zero so tried it on my pi 2 to see if the IOError’s continued, which they did.

Attached a picture of my soldering. If it was a bad connection/solder joint would the IOError’s be more consistent?

Tom


#8

Interestingly the sine.py example which uses set_buffer rather than set_pixel does not throw a single IOError.


#9

have you updated the package? they supressed the IO error… im unsure why theyre appearing but one thing to be aware of is that not all of the pins are required to be soldered on the scrollphat… doing this would reduce possibilities of soldering errors

check the pinouts here… its just 2 pins plus the power/ground

curl -sSL get.pimoroni.com/scrollphat | bash
sudo python ./setup.py install


#10

you should only get an error on 10 consectutive IO Errors

https://github.com/pimoroni/scroll-phat/commit/d5ed9770f2fb17f59ebbe1c953b8c7a89bfc0ccd


#11

A actually added the more verbose logging of the IOErrors back in to the update method as I wanted to see how frequently I was receiving them.

Without my verbose logging I guess I would get the normal "A high number of IO Errors have occured, please check your soldering/connections" message after around 10 minutes when using the progress.py example. If I increase the number of updates per second when using set_pixel the IO Error count of 10 is reached in less time.

I have a feeling it has something to do with the set_pixel method which updates the buffer list rather than pushing a new list when using set_buffer.

I’ve had sine.py running for 30 min without a single error with my verbose logging.

Thanks for the pin tip! Good to know if I grab another in the future.