Scroll pHAt Not working at all


#1

I soldered the GPIO header on to the raspberry pi and installed the requirements using the script given on github but my scroll pHAt will not light up at all, I have tried tyding up the soldering on the GPIO pins on the pi zero and reinstalling the requirements but still no luck, i fixed the fonts.png error but am still getting this one:
Traceback (most recent call last): File "/home/pi/Pimoroni/scrollphat/test-all.py", line 3, in <module> import scrollphat File "/usr/local/lib/python2.7/dist-packages/scrollphat.py", line 166, in <module> set_mode() File "/usr/local/lib/python2.7/dist-packages/scrollphat.py", line 68, in set_mode bus.write_i2c_block_data(I2C_ADDR, CMD_SET_MODE, [MODE_5X11]) IOError: [Errno 5] Input/output error

Can anyone help please as i am stumped as how to solve this as I haven’t a clue as a relative beginner, Unfortunately I only have a a zero and a B rather than a B+ or 2 so can’t check the scroll pHAT on another Pi

edit having had another look at some photos do I have to solder the female header onto the scroll pHAt board? Sorry if this sounds silly but the product page doesn’t make this clear and to a beginner I have been taking the assembled scroll board to mean i didn’t have to solder onto it?


#2

Yes, you must solder that header onto the Scroll pHAT :-)


#3

Thank you :-) I shall do that tomorrow
edit And i got it working thank you :-)


#4

#D’oh!

Yes, the header is rather important, isn’t it.

Mine now works too.


#5

My scroll pHAT doesn’t seem to be working despite installing the requirements via the script on github, I’ve copied the font.png to the scrollphat directory but I keep getting this error

Traceback (most recent call last):
File “count.py”, line 1, in
import scrollphat
File “/usr/local/lib/python2.7/dist-packages/scrollphat.py”, line 167, in
load_font()
File “/usr/local/lib/python2.7/dist-packages/scrollphat.py”, line 46, in load_font
font_image = Image.open(font_path)
File “/usr/lib/python2.7/dist-packages/PIL/Image.py”, line 2251, in open
fp = builtins.open(fp, “rb”)
IOError: [Errno 2] No such file or directory: ‘/usr/local/lib/python2.7/dist-packages/font.png’

Any ideas?


#6

Update I’ve sorted the error by copying the font.png to /usr/local/lib/python2.7/dist-packages and now my Scroll pHAT is working fine.


#7

I did the same thing.

To use the scroll hat in Python 3 as well, font.png has to be copied to

/usr/local/lib/python3.4/dist-packages/

I think that the file is being copied by the installation, but to the wrong location. It is ending up in /usr/local/lib or /usr/local, if I recall correctly.


#8

I just installed from github and have the same issue, I guess it’s not been fixed yet.


#9

I used the Debian Jesse Lite image to set up my Pi Zero. I had to install python-dev and python-imaging to get rid of the PIL error. No I also get the font.png message.
Where did you copy the font.png file from?


#10

Ok, I found it:
sudo cp /usr/local/font.png /usr/local/lib/python2.7/dist-packages
Now it works fine :-)


#11

Thanks, Konk, I was missing python-imaging. Also had downloaded the font.png webpage and not the raw image some how. The path in github, if you don’t have it is.

https://raw.githubusercontent.com/pimoroni/scroll-phat/master/library/font.png


#12

Hey all, there’s obviously something up with our installer for Scroll pHAT and we’re looking into it. It should be as simple as running the one-liner and you’re away. We’ll have an update soon! In the mean time thanks for supporting each other and figuring these bits out - it’s a very new product and we’ve been extremely busy recently but we’re looking into it!


#13

The one-line installer up now should get the Scroll pHAT running on Jessie. For Wheezy it’s a big can of worms and the plan is to do away with the PIL/pillow requirement.

… in the meantime, as @Richard pointed out python-imaging should fill the gap for Wheezy, but it’s Python2 only (unless you fight a battle or two).


#14

Hi guys!

I wanted to try my scroll phat soldered only to the necessary pins for my project.

Well, soldering only to the two I2c pins won’t cut it, as I get the same error as the OP.

I guuss power and ground are needed? Which pins on the scroll phat are power and ground?

Thanks!


#15

See this topic:
http://forums.pimoroni.com/t/scroll-phat-which-pins/1529/6