Scrollphathd not working


#1

Hello. I’m new to the forum.

I purchased a scroll bot kit and am not having any luck getting pixels to light up.

Soldering of the headers appears to be solid.

The scrollphathd sw installed correctly using:
curl https://get.pimoroni.com/scrollphathd | bash
except for errors installing the smbus for python2 and python3.
After researching this issue and installing smbus separately it appears to be working.

I have enabled Ic2 and get back numeric values in the the matrix when irunning:
sudo i2cdetect -y 1

The scrollphathd does have 5 volts and 3v on the appropriate pins.

When attempting to light a pixel with
set_pixel(1, 1, 1)
show()
the code runs without error but no pixels light.

Any suggestions on how to best troubleshoot this problem?


#2

Just for verification you ran
import scrollhathd
and
scrollphathd.set_pixel(1, 1, 1)
and
scrollphathd.show()


#3

Your the second person to report a smbus error? Same error in python, different hardware though?


#4

Yes, exactly. There was no error returned but the led did not light.


#5

Can you post good close up pictures of your soldering, pHat and Pi Zero Please?
Does i2c detect show the correct value, 0x74?


#6


Results of sudo i2cdetect -y 1


#7

Your soldering isn’t the best, I have seen worse though. The Scroll pHat looks pretty good, the Pi Zero IMHO, is a bit iffy soldering wise. Make sure no two GPIO are shorted together with a solder bridge. Especially the pins used by the scroll phat HD.


https://learn.pimoroni.com/tutorial/sandyj/the-ultimate-guide-to-soldering
Something is messed up with your i2c. It shouldn’t be showing numbers for every entry. There should just be the one 74 entry for the scroll phat hd, and any other i2c device connected. If the pHat is the only device there should just be the one 74.


#8

Might be a good idea to run i2c detect, with and without the scrollphat hd attached. That might clue you in to where the glitch is, and where to look.


#9

alphanumeric - thanks for helping me with this problem. Have not had much time to work on this because of the holidays.

I did reflow the solder joints on the pi and hopefully it is a better job.

Where I stand now is the pHat is not being detected. Running i2cdetect -y 1 shows only dashes in the matrix both with and without the hat. Any suggestions on next steps?


#10

Ok, redoing the soldering on the Pi (while it may not seem so) appears to have maybe helped things. i2c detect should show just dashes with nothing connected to the Pi. It should be blank.
With the Scroll pHat HD attached though, you should see a one lone 74. Your not seeing that so something is still amiss.
Do you have any other Hats or pHats that use i2c? Even one of the breakout garden boards like a BME680 would do. Just to see if i2c is now working on the Pi? If you can plug something else in and it shows up in i2c detect we will know the Pi end is now working.
Similarily, you don’t happen to have another Pi to test with? Doesn’t matter what model as long as it has a GPIO header on it. You could plug the scroll pHat into it and see if its picked up by i2c detect. Then with a process of elimination you could figure out if the issue is with the Pi or pHat or maybe both?

My Linux skills are a bit basic, just to be honest. I am a trained Electronic Technician though.


#11

Good suggestions. I do not have another hat, but did try the scrollphathd on a different PI. I2cdetect did not find the scrollphathd so I am guessing it is the problem.


#12

Check the soldering on pins 3 and 5, thats the i2c bus. Pin 2 is the +5V in and it uses pin 9 for ground. I didn’t see anything obvious in your picture of the soldering on the scroll pHat but maybe you have a cold solder joint or something?
A looking straight down picture of the soldering on that end of the GPIO might help.


#13

I checked the joints on the pins you recommended. They looked fine, but I reflowed them anyway. Still no luck.

Decided to order a second ScrollpHatHD to help in the troubleshooting, so will wait until that arrives to continue working on this.

Thanks again alphanumeric for your assistance with this.


#14

Soldering is second nature to me now after all these years doing it.
What I do is touch the tip of the iron so its touching the pin and the pad on the board at the same time. Wait a couple of seconds and then apply a small amount of solder. Then a second or so later I lift my tip straight up the pin. Not to the side. Less chance of solder going where you don’t want it too. You don’t have to cover the whole pin with solder. All you need is enough solder to encircle the base of the pin.
Another thing I do is skip every second pin. Solder 1, 5, 9 etc. Then go back and solder 3, 7, 11 etc.
Then 2, 6, 10, etc and then 4 , 8, 12, etc. It spreads the heat out so there is less chance of damaging something. By the time you get to the end of the row and go back the first pin you soldered has cooled off.


#15

I received the new ScrollpHatHD, soldered the connector and it seems to be working just fine. Either my soldering messed up the 1st one or it had a problem from the factory.

alphanumeric, your soldering tips and other help are much appreciated.


#16

Glad to help. Have fun with your working Scroll Hat HD.
It’s the nature of the beast. Boards that use surface mount components require a separate manufacturing step for any through hole parts like headers. Its quicker, easier, and cheaper to just put the header in the box and let the buyer worry about it. It makes the package slimmer too, and no worry of the header getting bent. No big deal if you know how to solder, not so good if you’ve never done it before.
I personally like having the option to use a different header, like a 90 degree header. Or change the gender from male to female. Or use a stacking header etc.
The Pi Zero with header was one answer to those that didn’t want to have to do it themselves. The hammer headers was another option with no soldering required.