Scrollphat cant find python3-psutil


#1

I’ve got a PI2 and the Scrollphat, but when I run the sudo curl -sSL get.pimoroni.com/scrollphat | bash everything goes fine until it tries to find python3-psutil and i get the message

Sorry, Apt failed to install python3-psutil, I can’t continue!


#2

can you let me know what OS you’re on. You can do the following to find out:

cat /etc/os-release

other than that, try to run apt-get update then try the script again, I sort of have an inkling as to what might be going on.


#3

Hi its the following
PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
NAME="Raspbian GNU/Linux"
VERSION_ID="7"
VERSION="7 (wheezy)"
ID=raspbian
ID_LIKE=debian
ANSI_COLOR="1;31"
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

Also during running the install script I see the error message
dpkg-query: no packages found matching python3-psutil


#4

yes, that is right… psutil is not in the Apt repo for Raspbian Wheezy. It will be fixed but right now, you can:

sudo pip-3.2 install psutil

that should do it.


#5

That I can install, but the script still seems to require the python3-psutil and stops at the install. Is there a way to override it? I thought about removing it from the pkgdeplist but then get Failed building wheel for pillow error instead

Perhaps a simpler install that doesnt require it ?


#6

This module is totally dispensable, it is just used for one of the example.

The pillow error is completely separate, it’s a failure from the pip repo. I need to discuss with @gadgetoid what we are going to do about this puppy because it is a troublemaker for sure ;-)


#7

does that mean it does not work with anything other than the zero at present?


#8

no, not at all, it’s trickier to get going on Wheezy as opposed to Jessie however as there is no easy way to fall back on the apt repo when pip craps out as it seems to be doing here.


#9

so how can i get this to work as its advertised to work with a pi 2, or has it never been tested as such?


#10

Yes, again this has nothing to do with the type of Pi but you’d have to upgrade your OS to Jessie, or if you are happy with using python 2 then I think it’s possible to work around. Well, everything is possible if you are willing to compile pillow from source.


#11

Sorry, it got pretty hectic my end earlier so my answer did not outline how you can upgrade your system…

… first of all I highly recommend you start from a fresh Jessie image, but sometimes it isn’t practical. You CAN upgrade your Raspbian to Jessie from its current state though, but this carries risks so make sure you back up your SD.

Also, unless you have a 16GB SD don’t even try to switch your distro as you’ll likely run out of space, which will lead to a set of obstacles to overcome by itself… see the following link on that subject: https://www.raspberrypi.org/documentation/raspbian/updating.md

Once you are ready to take the leap, check out this link that will tell you what the process is. Allow plenty of time too!

https://www.raspberrypi.org/forums/viewtopic.php?f=66&t=121880

Ultimately, this may not be worth the hassle. It IS possible that the pip issue regarding pillow will work itself out in the near future, it is after all required for the ridiculously popular sense HAT from the foundation ;-)


#12

The upgrade to Jessie worked, but the scrollphat didnt at first. There were issues with missing font.png and then IO zip errors and PIL errors
Did a lot of deleting Pil, delete and install of pillow and Pillow, then followed some instructions that loaded a zlib and then re-install the pillow and eventually got it to work.
I’ve got 270 of these to make :( so will revert to the arduino version