Sensehat not displaying text RPI4

I’ve recently got a sensehat. When trying to run any basic python script it doesn’t display any text. However, when I run a script that changes color depending on temperature, sense hat changes color but still not displaying text.
I have a fanshim attached to RPI, but I don’t think it would interfere with the sensehat
First time I tried to set up sensehat, it did work after adding “dtoverlay=rpi-sense” to boot/config.txt
When I boot my RPI4, sense hat lights up but stops when boot is completed, I think that’s normal
I’ve been trying for a solution but no luck so far

I would really appreciate any help on this issue

I have two Sense Hats plugged into Pi A+'s. (A+ not a 3A+) Those Pi’s aren’t running Buster though. Stretch I think?
Having to add dtoverlay=rpi-sense usually means the Sense hats ID eeprom isn’t being read for some reason.
The Sense Hat pinout is here

and the Fan Shim here

I don’t see any conflicts. BCM 3 (wake) is only grounded if the Fan Shim Button is pressed. i2c should still work OK.
I show a continuously scrolling repeating message on my Sense Hat. Day, date, time, temp, humidity , pressure. The text changes color based on the readings taken. Blue text for temp if its 0c or below for example. Post your code and I’ll have a look see.
If you want to try my file try the file in this folder. It’s my public OneDrive folder.
My Pi is flipped 180 so your text may be upside down!AjOYwiwlwDtpgsVj0KxSiXTcBZlfOQ?e=h2LgSd

The rainbow display on the LED matrix during boot up is normal. It going away when the Pi boots up is also normal.

Thanks for your reply,
Still getting same output:
Scrolling changing colours, but not text

With your code or my code?

yes, this is with your code

So what exactly do you see? The above statement I find confusing?
With my code the day date time will always be that off white. The other individual elements will change though, the text for each one and the reading for each one.
Are you running it in python 2 or python 3? I run mine in python 3.

I am using python 3.
I just see bands of srolling leds, changing colour, but not displaying any text at all.
If I could attach a video here…

If sounds like you Sense Hat has failed some how?
If it was me, I’d do up a fresh install of Buster on the Pi 4. I’d do my setup of Buster with the Sense hat removed. Leave the fan shim off for now.
Shutdown and attach the Sense Hat. Only do the dtoverlay=rpi-sense if you have to. Then try your code again. Or my code. I think its a hardware issue not a software issue. I have some stuff to do so I may not reply for a while.

Ok, thanks
I am afraid it’s a hardware issue

A friend of mine has a RPI , so I am going to try my sensehat on it
Thanks for your help

It should work on any Pi with a 40 pin GPIO. All the drivers are required software is included in Raspbian.

I think this is a hardware issue from either pin extender or senseHat, I dont think threre is something wrong with the RPI4.
I would like to send it back to Pimoroni, so we can determine where the problem is.
Could you give me instructions to send the senseHat back?

Go here to contact Pimoroni. I’d put a link to this thread in that e-mail.

Ok, thanks for your help