Setting explorer hat from PC to Pi Zero via SD card


#1

I have copied the file ExploreHAT-0.4.2.tar onto my windows PC and plan to copy it to my SD card for my PiZero which has no wifi. Where should I put it on SD card and once I have done that how do I install it once back in my Pi zero.? I am running Jessie and am a complete beginner so please be as clear as possible and don’t assume that I know much at all about the Pi yet. I plan to use the explorer hat to control my stepper motor controller module which is why I need the 5 volt capability. Many thanks in advance.


#2

Explorer HAT will have some dependencies, so the source tar alone wont be sufficient.

You’ll probably need to grab the latest deb files from here:

And probably python-smbus from here:

It may involve a bit of trial and error as you run into required packages, but you can just drop these on boot and then install them with:

sudo dpkg -i /boot/*.deb

And if it complains about a missing dependency, you should look it up in:


#3

Thanks, that was quick I will have a play later and see what I can do and
let you know how I get on.


#4

Hi again,
sorry it will be obvious to you I am sure, but I just want
to check, can I use the * symbol in the install line or do I do it a file
at a time adding the names in place of the *. This stuff is all new to me
but with a bit of help I am sure I will get there. Thanks again


#5

No worries, we all start somewhere!

The * is a bash wildcard character, so that means it will automatically find all files ending with .deb and install them if you type it verbatim :D

It’s a way of saying “anything ending with .deb”


#6

I found explorerhat on the sd card release that was supplied in the pi zero
kit and using the add/remove software GUI i installed the python2 and
python3 versions. I assume the picture of an open box means it is
installed. when I try import explorehat in either a python 2 or 3 window it
says no module named explorerhat. Any ideas what I am doing wrong?


#7

I forgot to say , I am not connected to the internet does this need to be done before add/remove software will install explorerhat even though it comes up in the list. I do not intend to have the Pi zero connected to the internet once I have explorerhat working.


#8

you cannot use what you call the ‘Add/Remove’ software GUI inside Raspbian - anything that appears there is either installed (if marked as such) or an indication that the software/source can be downloaded from the Raspbian/RPi svn repository for installation.

in other words it will only work if you are connected to the Internet… the method suggested by @gadgetoid is the only way you can install the python library - or at least the most straightforward way - without being connected to the Internet.


#9

Hi again
I managed to get an internet connection via an ethernet
adaptor and installed the software following the web site instructions. All
seemed well but I don’t seem to be able to make things work I copied the
following line and tried running it and got the error message tagged on the
end. According to the Raspberry pi configuration GUI the i2c is turned on.
What do I need to do to coax this into life? I have a Raspberry Pi Zero and
an Explorer pHAT

pi@raspberrypi:~ $ sudo python -c 'import time, explorerhat;
explorerhat.light.on(); time.sleep(1); explorerhat.light.off()'
Warning, could not find Analog or Touch…
Please check your i2c settings!


#10

check your soldering, that is almost certainly the culprit.


#11

I tried this but as you can see that does not work either.

pi@raspberrypi:~ $ sudo apt-get install -y 12c-tools
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package 12c-tools

How do I find this package?


#12

you might like to check that you have i2c-tools, not 12c-tools - it should start with the letter i, rather than the number 1.


#13

Hi sorry , my fault but using i rather than 1 still seems to give the same error

pi@raspberrypi:~ $ sudo apt-get install -y i2c-tools
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package i2c-tools

How do I find this package?


#14

Hi,
I seem to have it working now. I had to go into raspberry pi configuration GUI and disable I2C in the interface menu the do the sudo apt-get install -y i2c-tools then reset I2C in the interface GUi again to enabled. Then when I did import explorerhat it came back with explorer pHAT detected. example files now seem to run fine. Thanks for the help, it is much appreciated. I can play with hardware now.