Setting up Retropie - in need of some help please


#1

Hi, I’ve put together a Picade kit and it all it all seems to be running ok. I’ve been trying out MAME with an xbox controller just to test it and it worked fine. However I’ve now connected up the Picade PCB and I can’t get the joystick and buttons configured properly. To begin with, only the joystick and one of the side buttons seems to be automatically recognised. So I’ve plugged in a keyboard to open up the Retropie menu and entered the configuration setup. If I hold down one of the buttons it detects the joystick and buttons and I’m able to go through and assign them as appropriate. When I exit this setup menu I’m able to navigate through the emulators and games. However, when I run a game, my buttons are no longer being detected, it’s gone back to the original joystick and one side button that had been automatically detected before. I’ve tried rebooting and going through the configuration process but the configuration keeps resetting each time I start a game. I also tried rebooting without starting a game but again, once rebooted only the joystick and one side button were working. I’d be grateful if someone could suggest what I might be doing wrong?

I’m very inexperienced with Raspberry Pi and Retropie and I’ve been trying to find instructions online on how to set up these with the Picade. I can only find instructions for building the Picade itself but nothing similair for setting up the software to work with the Picade. If you’re able to point me in the right direction there as well I’d be very grateful. Thanks.


Insert coin in mame
#2

The controller config in retropie only works with certain emulators (based on retroarch).

MAME has to be configured separately. To do this you need to have a keyboard plugged in. Launch any mame rom and then press the ‘TAB’ key on the keyboard. This will bring up the contol configuration for Mame. You need to configure the joysticks buttons (player1) and Coin1, buttons etc.

To change the binding just press enter on the keyboard and choose the desired input on the joystick (up, down, left, right etc) And the same for button1, 2 , 3

In short, The controller config in retropie only works in certain emulators (i.e SNES, Megadrive etc)

MAME and i beleive Neo Geo are done separately.

Hope this helps.


#3

Thank you, that worked perfectly for MAME.

I’m still having issues with Retroarch “remembering” my joystick and buttons configuration. I’ve found some instructions online which might help, I’m just having trouble getting my head round these different names like Retropie, Retroarch, Emulation Station, Libertro etc. It’s very confusing to me as I’ve never used this software before but hopefully I’ll get there. Thanks again for fixing my MAME. :)


#4

I barely have a clue when it comes to the gnitty gritty of this stuff- which is why I’m thankful we’ve got users who know what they’re talking about! Sadly there’s only so much “playing arcade games” I can pass off as work :D


#5

When you first run RetroPie it should ask to configure the controls,and based on the configuration entered, will generate input configurations for RetroArch based emulators and Emulation Station. As mentioned other emulators will need to be configured separately. On my original Kickstarter Picade the mapping is fine for mame4all, but if running a Pi2, you probably should switch to

As one of the main RetroPie devs and a Picade owner, it should work out of the box on the Picade - so on first boot, you should be able to hold a button down and it should say “keyboard” and ask for inputs to be configured. If your buttons don’t work at this point, then there may be an issue with your setup.

To help in more detail I will need more information. Are you using a fresh image of RetroPie 3.1 for example ? How are you powering your Pi ? When you first boot, which buttons/controls don’t work. If you plug in an external keyboard and drop to a terminal (f4 from within ES then press a key to stop ES restarting), and run “showkey --scancodes” do you get output for all controls ?


#6

BuZz

Are there any plans to be able to edit individual emulator controls from within emulation station in future revisions of Retropie?

The only thing i’m struggling with is, I can configure the controls in emulation station for the retroarch emu’s but the button mapping is not 100% correct.

i.e correct control map for N64 but not correct for SNES.


#7

The setting to automatically loading remappings is enabled by default in latest retropie, so you can just configure in RGUI and save.