Retropie and buttonmapping


#1

I got my Picade yesterday and assembled without any real problems. I use an Raspberry Pie 2 and have installed Retropie 3.0 on it.

I have an issue with mapping the buttons. Everything works fine in the menus, but in games they are messed up. In the retropie menu i select ‘Configure retroarch joystick/keyboard’. If I try to configure joystick it tells me there’s no joystick detected. How do I set up the joystick so that I can use it in the different emulators? Thx in advance


#2

I believe the issue here is that the Picade joystick isn’t really a joystick as far as the emulator is concerned. It’s mapped onto keyboard keys.

@gadgetoid should be able to offer more guidance on this!


#3

Ok. I just tried using ‘configure keyboard for use with RetroArch’ but didn’t get it to work. Only a few of the buttons seemed to work in that setup. I know all the buttons work since the initial setup in RetroPie worked fine.


#4

This may help you with the controls. Although this is using RetroPie 3.2.1


#5

There is no need to use the “configure keyboard for use with RetroArch” with retropie 3.0 or greater. When you first boot and configure emulationstation the input provided there is then used to configure retroarch. (and as floob has shown you can manually customise later if you prefer)